{"answers":{"affected":"3 open source packages ship an affected version, including pdm.","exploited":"There is no known exploitation of CVE-2026-47764 in the wild and no public exploit code.","fix":"Upgrade pdm to 2.27.0 or later.","what":"CVE-2026-47764 is a high-severity path traversal vulnerability in pdm-project pdm, published on 4 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-47764 and fix it if it is affected.\n\nWhat it is: CVE-2026-47764 is a high-severity path traversal vulnerability in pdm-project pdm, published on 4 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-47764 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pdm (PyPI): affected all versions; fixed in 2.27.0\n- pdm (PyPI): affected all versions; fixed in 2.27.0\n- pdm (PyPI): affected all versions; fixed in 2.27.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-47764/ (Markdown: https://insights.sbomify.com/CVE-2026-47764/index.md)","id":"CVE-2026-47764","markdown":"https://insights.sbomify.com/CVE-2026-47764/index.md","name":"CVE-2026-47764","record":{"aliases":["DEBIAN-CVE-2026-47764","GHSA-78v8-vpjp-cjqh","PYSEC-2026-2861","UBUNTU-CVE-2026-47764"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python package manager","requires_auth":"none","summary":"A path traversal vulnerability in pdm allows attackers to write arbitrary files via malicious wheels, potentially leading to code execution or data modification.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"pdm is a Python package and dependency manager supporting the latest PEP standards. Versions prior to 2.27.0 are vulnerable to path traversal through write_to_fs. InstallDestination.write_to_fs() in src/pdm/installers/installers.py overrides the base class to add symlink/hardlink support but replaces the safe _path_with_destdir() (which validates via Path.resolve() + is_relative_to()) with a bare os.path.join() that performs no path validation. A malicious wheel with traversal entries can write arbitrary files. This issue has been fixed in version 2.27.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pdm: Path traversal in wheel installation via overridden write_to_fs","id":"CVE-2026-47764","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Frappe: Lack of Permissions in restore/bulk_restore","id":"CVE-2026-47765"},"packages":[{"ecosystem":"PyPI","fixed":["2.27.0"],"introduced":["0"],"last_affected":[],"package":"pdm","purl":null,"source":"GHSA-78v8-vpjp-cjqh"},{"ecosystem":"PyPI","fixed":["2.27.0"],"introduced":["0"],"last_affected":[],"package":"pdm","purl":"pkg:pypi/pdm","source":"GHSA-78v8-vpjp-cjqh"},{"ecosystem":"PyPI","fixed":["2.27.0"],"introduced":["0"],"last_affected":[],"package":"pdm","purl":"pkg:pypi/pdm","source":"PYSEC-2026-2861"}],"prev":{"headline":"pdm: Project-Local State and Config Writes Follow Symlinks","id":"CVE-2026-47763"},"products":["pdm"],"published":"2026-08-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-05","vendors":["pdm-project"]},"summary":"A path traversal vulnerability in pdm allows attackers to write arbitrary files via malicious wheels, potentially leading to code execution or data modification.","url":"https://insights.sbomify.com/CVE-2026-47764/"}