# CVE-2026-47764: pdm: Path traversal in wheel installation via overridden write_to_fs

> A path traversal vulnerability in pdm allows attackers to write arbitrary files via malicious wheels, potentially leading to code execution or data modification.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-47764, GHSA-78v8-vpjp-cjqh, PYSEC-2026-2861, UBUNTU-CVE-2026-47764

## What is CVE-2026-47764?

CVE-2026-47764 is a high-severity path traversal vulnerability in pdm-project pdm, published on 4 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

pdm is a Python package and dependency manager supporting the latest PEP standards. Versions prior to 2.27.0 are vulnerable to path traversal through write_to_fs. InstallDestination.write_to_fs() in src/pdm/installers/installers.py overrides the base class to add symlink/hardlink support but replaces the safe _path_with_destdir() (which validates via Path.resolve() + is_relative_to()) with a bare os.path.join() that performs no path validation. A malicious wheel with traversal entries can write arbitrary files. This issue has been fixed in version 2.27.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-47764?

3 open source packages ship an affected version, including pdm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pdm` | PyPI | All versions | 2.27.0 |
| `pdm` | PyPI | All versions | 2.27.0 |
| `pdm` | PyPI | All versions | 2.27.0 |

## How do I fix CVE-2026-47764?

Upgrade pdm to 2.27.0 or later.

## Is CVE-2026-47764 being exploited?

There is no known exploitation of CVE-2026-47764 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47764 and fix it if it is affected.

What it is: CVE-2026-47764 is a high-severity path traversal vulnerability in pdm-project pdm, published on 4 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-47764 in the wild and no public exploit code.

Affected packages and fixed versions:
- pdm (PyPI): affected all versions; fixed in 2.27.0
- pdm (PyPI): affected all versions; fixed in 2.27.0
- pdm (PyPI): affected all versions; fixed in 2.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47764/ (Markdown: https://insights.sbomify.com/CVE-2026-47764/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47764
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47764
- OSV: https://osv.dev/vulnerability/CVE-2026-47764

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47764/
Summaries are generated and may contain mistakes; the official description above is the record.
