# CVE-2026-47774: Envoy vulnerable to HTTP/2 memory exhaustion via cookie header size bypass and HPACK amplification

> Remote attackers can cause Envoy proxy denial of service via memory exhaustion using crafted HTTP/2 headers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 24 Aug 2026
- **Also known as:** BIT-envoy-2026-47774, GHSA-22m2-hvr2-xqc8

## What is CVE-2026-47774?

CVE-2026-47774 is a high-severity denial of service vulnerability in Envoyproxy Envoy, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.35.11, 1.36.7, 1.37.3, and 1.38.1, a vulnerability in Envoy's HTTP/2 downstream request processing allows an unauthenticated remote client to trigger excessive memory consumption, potentially resulting in OOM termination of the Envoy process and denial of service. The issue arises from the combination of two behaviors. First, cookie header bytes are not fully accounted for during request header size validation in Envoy. Second, HPACK header block limits in oghttp2/quiche are enforced on encoded bytes without a corresponding limit on total decoded header size. Together, these behaviors allow a malicious client to cause large decoded header allocations while bypassing the intended request header size protections. Versions 1.35.11, 1.36.7, 1.37.3, and 1.38.1 contain a fix. No complete workaround is known short of applying a fix. Possible temporary mitigations include disabling downstream HTTP/2 where operationally feasible; enforcing stricter request header and cookie limits before traffic reaches Envoy; and monitoring Envoy memory usage for abnormal growth under HTTP/2 traffic.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification)), CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-405 (Asymmetric Resource Consumption (Amplification))

## Which versions are affected by CVE-2026-47774?

1 open source package ship an affected version, including envoy. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | All versions | 1.35.11, 1.36.7, 1.37.3, 1.38.1 |

Products: Envoyproxy Envoy, Redhat Openshift Service Mesh.

## How do I fix CVE-2026-47774?

Upgrade envoy to a fixed version for your release line: 1.35.11, 1.36.7, 1.37.3 or 1.38.1.

## Is CVE-2026-47774 being exploited?

There is no known exploitation of CVE-2026-47774 in the wild and no public exploit code.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47774 and fix it if it is affected.

What it is: CVE-2026-47774 is a high-severity denial of service vulnerability in Envoyproxy Envoy, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47774 in the wild and no public exploit code.

Affected packages and fixed versions:
- envoy (Bitnami): affected all versions; fixed in 1.35.11, 1.36.7, 1.37.3, 1.38.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47774/ (Markdown: https://insights.sbomify.com/CVE-2026-47774/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47774
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47774
- OSV: https://osv.dev/vulnerability/CVE-2026-47774

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47774/
Summaries are generated and may contain mistakes; the official description above is the record.
