# CVE-2026-47781: pdm: Project-Controlled `.pdm-plugins` Content Executes Before CLI Parsing

> Attackers can execute arbitrary Python code via malicious project-local plugins in untrusted repositories, affecting developers and CI systems using PDM.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-47781, GHSA-qq6c-99pv-prvf, PYSEC-2026-2863, UBUNTU-CVE-2026-47781

## What is CVE-2026-47781?

CVE-2026-47781 is a high-severity code injection vulnerability in pdm-project pdm, published on 4 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PDM is a Python package and dependency manager. In versions up to and including 2.26.9, PDM automatically loads project-local plugins from a .pdm-plugins directory during initialization, allowing an attacker-controlled file in an untrusted repository checkout to execute arbitrary Python code before any command is parsed. This happens because load_plugins() runs during Core.init() and adds .pdm-plugins via site.addsitedir(), which processes .pth files and immediately executes any line beginning with import, so the code runs with the privileges of the user invoking pdm and even a benign command such as pdm --version triggers it (making the impact strongest in CI, automation, and privileged contexts). The issue is fixed in version 2.27.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2026-47781?

3 open source packages ship an affected version, including pdm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pdm` | PyPI | All versions | 2.27.0 |
| `pdm` | PyPI | All versions | 2.27.0 |
| `pdm` | PyPI | All versions | 2.27.0 |

## How do I fix CVE-2026-47781?

Upgrade pdm to 2.27.0 or later.

## Is CVE-2026-47781 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47781 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47781 and fix it if it is affected.

What it is: CVE-2026-47781 is a high-severity code injection vulnerability in pdm-project pdm, published on 4 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47781 exists.

Affected packages and fixed versions:
- pdm (PyPI): affected all versions; fixed in 2.27.0
- pdm (PyPI): affected all versions; fixed in 2.27.0
- pdm (PyPI): affected all versions; fixed in 2.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47781/ (Markdown: https://insights.sbomify.com/CVE-2026-47781/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47781
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47781
- OSV: https://osv.dev/vulnerability/CVE-2026-47781

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47781/
Summaries are generated and may contain mistakes; the official description above is the record.
