CVE-2026-47835 Spring AI vector store metadata filtering to handle special characters in Elasticsearch, OpenSearch, and GemFire Vector Stores
Attackers can inject arbitrary queries into Elasticsearch, OpenSearch, or GemFire vector stores via special characters in metadata filters, potentially leading to code execution or data exposure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-47835?
CVE-2026-47835 is a high-severity code injection vulnerability in Spring AI, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Spring AI Vector Stores, special characters could be used to force the execution of arbitrary queries in Elasticsearch, OpenSearch, and GemFire VectorDB. Affected components: spring-ai-elasticsearch-store, spring-ai-opensearch-store, spring-ai-gemfire-store.
Affected versions: Spring AI 1.0.0 through 1.0.x (fix 1.0.9). Spring AI 1.1.0 through 1.1.x (fix 1.1.8).
Weakness: CWE-943
Which versions are affected by CVE-2026-47835?
12 open source packages ship an affected version, including org.springframework.ai:spring-ai-elasticsearch-store, org.springframework.ai:spring-ai-gemfire-store and org.springframework.ai:spring-ai-opensearch-store. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework.ai:spring-ai-elasticsearch-store Maven | From 1.0.0 | 1.0.9 |
org.springframework.ai:spring-ai-elasticsearch-store Maven | From 1.0.0 | 1.0.9 |
org.springframework.ai:spring-ai-elasticsearch-store Maven | From 1.1.0 | 1.1.8 |
org.springframework.ai:spring-ai-elasticsearch-store Maven | From 1.1.0 | 1.1.8 |
org.springframework.ai:spring-ai-gemfire-store Maven | From 1.0.0 | 1.0.9 |
org.springframework.ai:spring-ai-gemfire-store Maven | From 1.0.0 | 1.0.9 |
6 more packages
org.springframework.ai:spring-ai-gemfire-store Maven | From 1.1.0 | 1.1.8 |
org.springframework.ai:spring-ai-gemfire-store Maven | From 1.1.0 | 1.1.8 |
org.springframework.ai:spring-ai-opensearch-store Maven | From 1.0.0 | 1.0.9 |
org.springframework.ai:spring-ai-opensearch-store Maven | From 1.0.0 | 1.0.9 |
org.springframework.ai:spring-ai-opensearch-store Maven | From 1.1.0 | 1.1.8 |
org.springframework.ai:spring-ai-opensearch-store Maven | From 1.1.0 | 1.1.8 |
Products include Vmware Spring Ai.
How do I fix CVE-2026-47835?
Upgrade org.springframework.ai:spring-ai-elasticsearch-store to a fixed version for your release line: 1.0.9 or 1.1.8.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-47835 being exploited?
There is no known exploitation of CVE-2026-47835 in the wild and no public exploit code.
Other vulnerabilities in Spring AI
- CVE-2026-22738 SpEL Injection via Unescaped Filter Key in SimpleVectorStore Leads to Remote Code Execution
- CVE-2026-40978 Spring AI has SQL Injection in CosmosDBVectorStore.doDelete()
- CVE-2026-22730 CVE-2026-22730: SQL Injection in Spring AI MariaDBFilterExpressionConverter
- CVE-2026-41705 Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs
- CVE-2026-40967 Spring AI has a VectorStore FilterExpression Converter injection
Sources
Also known as GHSA-cmwh-w62w-r2mf.