# CVE-2026-47846: Hardcoded credentials in bitnami/cassandra

> Attackers can use default credentials to gain superuser access in Bitnami Cassandra containers when custom admin accounts are configured.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jun 2026
- **Updated:** 18 Jun 2026
- **Also known as:** BIT-cassandra-2026-47846

## What is CVE-2026-47846?

CVE-2026-47846 is a critical vulnerability in bitnami/cassandra, published on 18 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Bitnami Cassandra container images are affected by a retained default superuser vulnerability. When a custom administrator account is configured via the CASSANDRA_USER environment variable, the container initialization script creates the new superuser account but fails to drop the built-in cassandra account in certain scenarios. This leaves the default cassandra:cassandra superuser active as an unintended access path.

Affected versions — Container image: 4.0.x prior to 4.0.20-photon-5-r7; 4.1.x prior to 4.1.11-photon-5-r7; 5.0.x prior to 5.0.8-photon-5-r4 / 5.0.8-debian-12-r3.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2026-47846?

1 open source package ship an affected version, including cassandra.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cassandra` | Bitnami | From 4.0.0 | 4.0.20-0, 4.1.11-0, 5.0.8-0 |

## How do I fix CVE-2026-47846?

Upgrade cassandra to a fixed version for your release line: 4.0.20-0, 4.1.11-0 or 5.0.8-0.

## Is CVE-2026-47846 being exploited?

There is no known exploitation of CVE-2026-47846 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47846 and fix it if it is affected.

What it is: CVE-2026-47846 is a critical vulnerability in bitnami/cassandra, published on 18 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47846 in the wild and no public exploit code.

Affected packages and fixed versions:
- cassandra (Bitnami): affected from 4.0.0; fixed in 4.0.20-0, 4.1.11-0, 5.0.8-0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47846/ (Markdown: https://insights.sbomify.com/CVE-2026-47846/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47846
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47846
- OSV: https://osv.dev/vulnerability/CVE-2026-47846

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47846/
Summaries are generated and may contain mistakes; the official description above is the record.
