# CVE-2026-47847: Hardcoded credentials in bitnami/mariadb-galera

> Attackers can use hardcoded default credentials to access MariaDB Galera replication data, requiring users to upgrade container images and Helm charts.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jun 2026
- **Updated:** 18 Jun 2026
- **Also known as:** BIT-mariadb-galera-2026-47847

## What is CVE-2026-47847?

CVE-2026-47847 is a medium-severity vulnerability in bitnami/mariadb-galera, published on 18 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Bitnami MariaDB Galera container images and Helm chart are affected by a hardcoded default credential vulnerability in the Galera replication health-check user. The MARIADB_REPLICATION_USER and MARIADB_REPLICATION_PASSWORD environment variables defaulted to monitor and monitor respectively. This user is granted REPLICATION CLIENT privileges from any host ('%'). The Bitnami Helm chart for MariaDB Galera did not expose parameters to configure this user's credentials, resulting in all chart deployments using this publicly known credential by default.

Affected versions — Container image: 10.6.x prior to 10.6.27-photon-5-r0; 10.11.x prior to 10.11.17-photon-5-r1; 11.4.x prior to 11.4.12-photon-5-r0; 11.8.x prior to 11.8.7-photon-5-r1; 12.3.x prior to 12.3.2-photon-5-r0 / 12.3.2-debian-12-r0. Helm chart: prior to 18.3.0.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2026-47847?

1 open source package ship an affected version, including mariadb-galera.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb-galera` | Bitnami | From 10.6.0 | 10.6.27-0, 10.11.17-0, 11.4.12-0, 11.8.7-0, 12.3.2-0 |

## How do I fix CVE-2026-47847?

Upgrade mariadb-galera to a fixed version for your release line: 10.6.27-0, 10.11.17-0, 11.4.12-0 or 11.8.7-0.

## Is CVE-2026-47847 being exploited?

There is no known exploitation of CVE-2026-47847 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47847 and fix it if it is affected.

What it is: CVE-2026-47847 is a medium-severity vulnerability in bitnami/mariadb-galera, published on 18 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47847 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb-galera (Bitnami): affected from 10.6.0; fixed in 10.6.27-0, 10.11.17-0, 11.4.12-0, 11.8.7-0, 12.3.2-0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47847/ (Markdown: https://insights.sbomify.com/CVE-2026-47847/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47847
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47847
- OSV: https://osv.dev/vulnerability/CVE-2026-47847

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47847/
Summaries are generated and may contain mistakes; the official description above is the record.
