CVE-2026-47869 VMware Avi Load Balancer Remote Code Execution Vulnerability

High 8.7 Published Updated

A malicious authenticated user can inject and execute arbitrary code on VMware Avi Load Balancer, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-47869?

CVE-2026-47869 is a high-severity code injection vulnerability in VMware Avi Load Balancer, published on 18 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

VMware Avi Load Balancer contains a remote code execution vulnerability. A malicious authenticated user with network access may be able to inject and execute code.

Affected versions: 32.1.1 (fixed in 32.1.2) 31.1.1 through 31.2.2 (fixed in 31.2.2-2p3) 30.1.1 through 30.2.6 (fixed in 30.2.7) 22.1.1 through 22.1.7 (fixed in 30.2.7)

Weakness: CWE-94

Which versions are affected by CVE-2026-47869?

It affects 1 product.

Products include Broadcom Vmware Avi Load Balancer.

How do I fix CVE-2026-47869?

No fix has been published for CVE-2026-47869 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-47869 being exploited?

There is no known exploitation of CVE-2026-47869 in the wild and no public exploit code.

Sources

Also known as GHSA-h452-q2fr-5rvh.

Is CVE-2026-47869 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free