CVE-2026-47870 VMware Avi Load Balancer Privilege Escalation Vulnerability
An authenticated user can escalate privileges to execute remote code on VMware Avi Load Balancer, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-47870?
CVE-2026-47870 is a high-severity vulnerability in VMware Avi Load Balancer, published on 18 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
VMware Avi Load Balancer contains a privilege escalation vulnerability. A malicious authenticated user with network access may be able to execute remote code.
Affected versions: 32.1.1 (fixed in 32.1.2) 31.1.1 through 31.2.2 (fixed in 31.2.2-2p3) 30.1.1 through 30.2.6 (fixed in 30.2.7) 22.1.1 through 22.1.7 (fixed in 30.2.7)
Weakness: CWE-269
Which versions are affected by CVE-2026-47870?
It affects 1 product.
Products include Broadcom Vmware Avi Load Balancer.
How do I fix CVE-2026-47870?
No fix has been published for CVE-2026-47870 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-47870 being exploited?
There is no known exploitation of CVE-2026-47870 in the wild and no public exploit code.
Other vulnerabilities in VMware Avi Load Balancer
- CVE-2026-47865 VMware Avi Load Balancer Authentication Bypass Vulnerability
- CVE-2026-47871 VMware Avi Load Balancer Directory Traversal Vulnerability
- CVE-2026-47867 VMware Avi Load Balancer Remote Code Execution Vulnerability
- CVE-2026-47869 VMware Avi Load Balancer Remote Code Execution Vulnerability
- CVE-2026-47866 VMware Avi Load Balancer Authorization Bypass Vulnerability
Sources
Also known as GHSA-x69w-rh5r-3wgj.