{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-47895 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-47895 is a high-severity use after free vulnerability in strongSwan, published on 22 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-47895 and fix it if it is affected.\n\nWhat it is: CVE-2026-47895 is a high-severity use after free vulnerability in strongSwan, published on 22 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-47895 in the wild and no public exploit code.\n\nAffected product: strongSwan. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-47895/ (Markdown: https://insights.sbomify.com/CVE-2026-47895/index.md)","id":"CVE-2026-47895","markdown":"https://insights.sbomify.com/CVE-2026-47895/index.md","name":"CVE-2026-47895","record":{"aliases":["ALPINE-CVE-2026-47895","AZL-97377","DEBIAN-CVE-2026-47895","GHSA-55p5-7gvc-767j","SUSE-SU-2026:22168-1","SUSE-SU-2026:2312-1","UBUNTU-CVE-2026-47895","USN-8407-1","openSUSE-SU-2026:11005-1","openSUSE-SU-2026:21092-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"IPsec VPN software","requires_auth":"low_privilege","summary":"A double-free vulnerability in strongSwan's EAP-Identity parsing allows remote attackers to cause a denial of service.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-415","name":"Double Free"}],"description":"In strongSwan before 6.0.7, identity parsing/cloning is mishandled. Parsed EAP-Identities that result in an empty but non-NULL encoding are not correctly cloned and trigger a double-free once the duplicates are destroyed.","ecosystems":["SUSE:Linux Enterprise Server 12 SP5-LTSS","SUSE:Linux Enterprise Server 16.0","SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","SUSE:Linux Enterprise Server for SAP applications 16.0","openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use after free in strongSwan","id":"CVE-2026-47895","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"use_after_free","year":"2026"},"n_packages":6,"n_references":2,"next":{"headline":"Apache Lucene.Net: Unauthenticated arbitrary file read on the Lucene.Net.Replicator replication server","id":"CVE-2026-47896"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5-LTSS","fixed":["5.1.3-26.38.1"],"introduced":["0"],"last_affected":[],"package":"strongswan","purl":"pkg:rpm/suse/strongswan\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5-LTSS","source":"SUSE-SU-2026:2312-1"},{"ecosystem":"SUSE:Linux Enterprise Server 16.0","fixed":["6.0.6-160000.2.1"],"introduced":["0"],"last_affected":[],"package":"strongswan","purl":"pkg:rpm/suse/strongswan\u0026distro=SUSE%20Linux%20Enterprise%20Server%2016.0","source":"SUSE-SU-2026:22168-1"},{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["5.1.3-26.38.1"],"introduced":["0"],"last_affected":[],"package":"strongswan","purl":"pkg:rpm/suse/strongswan\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2026:2312-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP applications 16.0","fixed":["6.0.6-160000.2.1"],"introduced":["0"],"last_affected":[],"package":"strongswan","purl":"pkg:rpm/suse/strongswan\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20applications%2016.0","source":"SUSE-SU-2026:22168-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["6.0.6-160000.2.1"],"introduced":["0"],"last_affected":[],"package":"strongswan","purl":"pkg:rpm/opensuse/strongswan\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:21092-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["6.0.7-1.1"],"introduced":["0"],"last_affected":[],"package":"strongswan","purl":"pkg:rpm/opensuse/strongswan\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11005-1"}],"prev":{"headline":"Spring Cloud Config Server Native Environment Repository Exposure","id":"CVE-2026-47894"},"products":["strongSwan"],"published":"2026-08-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-24","vendors":["strongSwan"]},"summary":"A double-free vulnerability in strongSwan's EAP-Identity parsing allows remote attackers to cause a denial of service.","url":"https://insights.sbomify.com/CVE-2026-47895/"}