# CVE-2026-48010: Shopware: Privilege escalation: non-admin user with user:create ACL can create admin accounts

> A non-admin user with create permissions can escalate privileges to admin by setting the admin flag during user creation due to missing validation.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** GHSA-v39m-97p8-gqg7

## What is CVE-2026-48010?

CVE-2026-48010 is a medium-severity vulnerability in shopware platform, published on 17 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Shopware is an open commerce platform. Prior to 6.6.10.18 and 6.7.10.1, UserController::upsertUser() in src/Core/Framework/Api/Controller/UserController.php writes raw user data in SYSTEM_SCOPE without filtering the admin field, so a non-admin API user with user:create or user:update ACL permission can set admin: true on new or existing users; IntegrationController::upsertIntegration() contains an isAdmin() check for the same field, but UserController was missing this check. This issue is fixed in versions 6.6.10.18 and 6.7.10.1.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-48010?

8 open source packages ship an affected version, including shopware/platform and shopware/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/platform` | Packagist | All versions | 6.6.10.18 |
| `shopware/platform` | Packagist | All versions | 6.6.10.18 |
| `shopware/platform` | Packagist | From 6.7.0.0 | 6.7.10.1 |
| `shopware/platform` | Packagist | From 6.7.0.0 | 6.7.10.1 |
| `shopware/core` | Packagist | All versions | 6.6.10.18 |
| `shopware/core` | Packagist | All versions | 6.6.10.18 |
| `shopware/core` | Packagist | From 6.7.0.0 | 6.7.10.1 |
| `shopware/core` | Packagist | From 6.7.0.0 | 6.7.10.1 |

## How do I fix CVE-2026-48010?

Upgrade shopware/platform to a fixed version for your release line: 6.6.10.18 or 6.7.10.1.

## Is CVE-2026-48010 being exploited?

There is no known exploitation of CVE-2026-48010 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48010 and fix it if it is affected.

What it is: CVE-2026-48010 is a medium-severity vulnerability in shopware platform, published on 17 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48010 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/platform (Packagist): affected all versions; fixed in 6.6.10.18
- shopware/platform (Packagist): affected all versions; fixed in 6.6.10.18
- shopware/platform (Packagist): affected from 6.7.0.0; fixed in 6.7.10.1
- shopware/platform (Packagist): affected from 6.7.0.0; fixed in 6.7.10.1
- shopware/core (Packagist): affected all versions; fixed in 6.6.10.18
- shopware/core (Packagist): affected all versions; fixed in 6.6.10.18
- shopware/core (Packagist): affected from 6.7.0.0; fixed in 6.7.10.1
- shopware/core (Packagist): affected from 6.7.0.0; fixed in 6.7.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48010/ (Markdown: https://insights.sbomify.com/CVE-2026-48010/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48010
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48010
- OSV: https://osv.dev/vulnerability/CVE-2026-48010

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48010/
Summaries are generated and may contain mistakes; the official description above is the record.
