CVE-2026-48016 Shopware: Unauthorized Payment Trigger for Foreign Orders via /store-api/handle-payment
Attackers can trigger payment flows for other users' orders via the Store API due to missing ownership verification, potentially disrupting transactions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-48016?
CVE-2026-48016 is a medium-severity missing authorization vulnerability in shopware platform, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Shopware is an open commerce platform. Prior to 6.6.10.18 and 6.7.10.1, the Store API endpoint /store-api/handle-payment in src/Core/Checkout/Payment/SalesChannel/HandlePaymentMethodRoute.php accepts a user-controlled orderId and forwards it to src/Core/Checkout/Payment/PaymentProcessor.php without verifying order ownership or guest-order authentication, allowing a normal customer or guest context to trigger the payment flow for another user's order while /store-api/order enforces the expected ownership model. This issue is fixed in versions 6.6.10.18 and 6.7.10.1.
Weakness: CWE-639
Which versions are affected by CVE-2026-48016?
8 open source packages ship an affected version, including shopware/platform and shopware/core.
| Package | Affected | Fixed in |
|---|---|---|
shopware/platform Packagist | All versions | 6.6.10.18 |
shopware/platform Packagist | All versions | 6.6.10.18 |
shopware/platform Packagist | From 6.7.0.0 | 6.7.10.1 |
shopware/platform Packagist | From 6.7.0.0 | 6.7.10.1 |
shopware/core Packagist | All versions | 6.6.10.18 |
shopware/core Packagist | All versions | 6.6.10.18 |
2 more packages
shopware/core Packagist | From 6.7.0.0 | 6.7.10.1 |
shopware/core Packagist | From 6.7.0.0 | 6.7.10.1 |
How do I fix CVE-2026-48016?
Upgrade shopware/platform to a fixed version for your release line: 6.6.10.18 or 6.7.10.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-48016 being exploited?
There is no known exploitation of CVE-2026-48016 in the wild and no public exploit code.
Sources
Also known as GHSA-9v5m-39wh-5chq.