# CVE-2026-48017: DbGate: Remote Code Execution via functionName injection in loadReader endpoint

> Authenticated users can inject JavaScript into the loadReader endpoint to execute arbitrary code and commands on the DbGate server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jun 2026
- **Updated:** 23 Jul 2026
- **Also known as:** GHSA-hv83-ggc4-v385

## What is CVE-2026-48017?

CVE-2026-48017 is a high-severity code injection vulnerability in dbgate, published on 15 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

DbGate is cross-platform database manager. In versions 7.1.8 and prior, the POST /runners/load-reader endpoint in DbGate accepts a functionName parameter that is directly interpolated into a JavaScript code template without any sanitization or validation. An authenticated user (with basic access, no special permissions required) can inject arbitrary JavaScript code that executes on the server with full process privileges, bypassing the require=null sandbox restriction. An authenticated user with basic access (no admin role, no run-shell-script permission required) can: execute arbitrary OS commands on the DbGate server with the privileges of the Node.js process, read/write any file accessible to the process, pivot to connected databases by reading connection credentials from DbGate's storage, and compromise the host system - in Docker deployments, this typically means root access within the container. Version 7.1.9 contains a patch.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-48017?

2 open source packages ship an affected version, including dbgate-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dbgate-api` | npm | All versions | 7.1.9 |
| `dbgate-api` | npm | All versions | 7.1.9 |

## How do I fix CVE-2026-48017?

Upgrade dbgate-api to 7.1.9 or later.

## Is CVE-2026-48017 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48017 exists.

Public exploit code:

- Remote Code Execution in DbGate via functionName injection in the loadReader endpoint — CVSS 8.8 (github_poc): https://github.com/romain-deperne/CVE-2026-48017

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48017 and fix it if it is affected.

What it is: CVE-2026-48017 is a high-severity code injection vulnerability in dbgate, published on 15 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48017 exists.

Affected packages and fixed versions:
- dbgate-api (npm): affected all versions; fixed in 7.1.9
- dbgate-api (npm): affected all versions; fixed in 7.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48017/ (Markdown: https://insights.sbomify.com/CVE-2026-48017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48017
- OSV: https://osv.dev/vulnerability/CVE-2026-48017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48017/
Summaries are generated and may contain mistakes; the official description above is the record.
