{"answers":{"affected":"2 open source packages ship an affected version, including @hapi/wreck.","exploited":"There is no known exploitation of CVE-2026-48022 in the wild and no public exploit code.","fix":"Upgrade @hapi/wreck to 18.1.2 or later.","what":"CVE-2026-48022 is a medium-severity vulnerability in hapijs wreck, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-48022 and fix it if it is affected.\n\nWhat it is: CVE-2026-48022 is a medium-severity vulnerability in hapijs wreck, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-48022 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @hapi/wreck (npm): affected all versions; fixed in 18.1.2\n- @hapi/wreck (npm): affected all versions; fixed in 18.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-48022/ (Markdown: https://insights.sbomify.com/CVE-2026-48022/index.md)","id":"CVE-2026-48022","markdown":"https://insights.sbomify.com/CVE-2026-48022/index.md","name":"CVE-2026-48022","record":{"aliases":["GHSA-x426-x7cc-3fpc","MINI-3478-4g29-54qw","MINI-4858-rr3g-gvhm","MINI-4gm5-8q5x-rx9r","MINI-6q84-77wm-wr7r","MINI-748x-xv56-r9v7","MINI-7p3r-c928-3xrq","MINI-7rfp-pjg4-4qr8","MINI-8m5g-7jw6-x79q","MINI-fr45-j7r7-vq63","MINI-g93v-xcjm-gpv7","MINI-hcpj-p2p2-x8rv","MINI-v8cv-6v99-m3ww","MINI-vq48-3rv5-8pf2","MINI-vvxv-c3qx-xmfr","MINI-wf9x-gwxm-6fpg","ROOT-APP-NPM-CVE-2026-48022"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP client","requires_auth":"none","summary":"An attacker can capture sensitive credentials like tokens and cookies by exploiting a flaw in cross-origin redirect handling that ignores scheme and port changes.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"},{"id":"CWE-346","name":"Origin Validation Error"},{"id":"CWE-319","name":"Cleartext Transmission of Sensitive Information"}],"description":"@hapi/wreck is an HTTP client utility. Prior to 18.1.2, Wreck strips credential headers including Authorization, Cookie, and Proxy-Authorization before following a cross-origin redirect, but the origin check compares hostnames only and ignores scheme and port, so credentials are forwarded intact across same-host port changes and HTTPS-to-HTTP downgrades, allowing a co-tenant on an adjacent port or a network-position attacker capable of forging a redirect to capture bearer tokens, session cookies, and proxy credentials and impersonate the victim against the upstream service. This issue is fixed in version 18.1.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"@hapi/wreck: Sensitive credential headers leak across cross-port and cross-scheme redirects","id":"CVE-2026-48022","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Wazuh: merged-file header path traversal in cluster sync allows arbitrary file write under WAZUH_PATH in Wazuh manager","id":"CVE-2026-48024"},"packages":[{"ecosystem":"npm","fixed":["18.1.2"],"introduced":["0"],"last_affected":[],"package":"@hapi/wreck","purl":null,"source":"GHSA-x426-x7cc-3fpc"},{"ecosystem":"npm","fixed":["18.1.2"],"introduced":["0"],"last_affected":[],"package":"@hapi/wreck","purl":"pkg:npm/%40hapi/wreck","source":"GHSA-x426-x7cc-3fpc"}],"prev":{"headline":"Security feature bypass in epa4all","id":"CVE-2026-48021"},"products":["wreck"],"published":"2026-07-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-20","vendors":["hapijs"]},"summary":"An attacker can capture sensitive credentials like tokens and cookies by exploiting a flaw in cross-origin redirect handling that ignores scheme and port changes.","url":"https://insights.sbomify.com/CVE-2026-48022/"}