# CVE-2026-48030: Pheditor: OS Command Injection in terminal handler via unsanitized 'dir' parameter (CWE-78)

> Authenticated users can execute arbitrary OS commands via the terminal handler's dir parameter, leading to remote code execution.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2026
- **Updated:** 27 Jul 2026
- **Also known as:** GHSA-jvc5-6g7q-c843

## What is CVE-2026-48030?

CVE-2026-48030 is a critical command injection vulnerability in pheditor, published on 27 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pheditor is a single-file editor and file manager written in PHP. From version 2.0.1 to before version 2.0.4, an OS Command Injection vulnerability in the terminal action handler allows any authenticated user to execute arbitrary OS commands by injecting shell metacharacters into the 'dir' POST parameter, completely bypassing the TERMINAL_COMMANDS whitelist and achieving full Remote Code Execution with web server privileges. This issue has been patched in version 2.0.4.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-48030?

2 open source packages ship an affected version, including pheditor/pheditor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pheditor/pheditor` | Packagist | From 2.0.1 | 2.0.4 |
| `pheditor/pheditor` | Packagist | From 2.0.1 | 2.0.4 |

## How do I fix CVE-2026-48030?

Upgrade pheditor/pheditor to 2.0.4 or later.

## Is CVE-2026-48030 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48030 exists.

Public exploit code:

- https://github.com/muslimbek-0x/CVE-2026-48030 (github_poc): https://github.com/muslimbek-0x/CVE-2026-48030
- Pheditor 2.0.1-2.0.3 - OS Command Injection (nuclei): http/cves/2026/CVE-2026-48030.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48030 and fix it if it is affected.

What it is: CVE-2026-48030 is a critical command injection vulnerability in pheditor, published on 27 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48030 exists.

Affected packages and fixed versions:
- pheditor/pheditor (Packagist): affected from 2.0.1; fixed in 2.0.4
- pheditor/pheditor (Packagist): affected from 2.0.1; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48030/ (Markdown: https://insights.sbomify.com/CVE-2026-48030/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48030
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48030
- OSV: https://osv.dev/vulnerability/CVE-2026-48030

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48030/
Summaries are generated and may contain mistakes; the official description above is the record.
