# CVE-2026-48032: Hulumi: IAM-role policy checks bypassed when the role trusts multiple OIDC providers

> Attackers can bypass IAM-role policy checks in Hulumi when roles trust multiple OIDC providers, potentially escalating privileges.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jul 2026
- **Updated:** 27 Jul 2026
- **Also known as:** GHSA-g759-4pxw-6692

## What is CVE-2026-48032?

CVE-2026-48032 is a high-severity authentication bypass vulnerability in kerberosmansour hulumi, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hulumi is an open-source toolkit that ships secure-by-default cloud and platform infrastructure components for Pulumi. Prior to version 1.4.0, IAM-role policy checks can be bypassed when the role trusts multiple OIDC providers. This issue has been patched in version 1.4.0.

Weakness: CWE-697 (Incorrect Comparison)

## Which versions are affected by CVE-2026-48032?

2 open source packages ship an affected version, including @hulumi/policies.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@hulumi/policies` | npm | All versions | 1.4.0 |
| `@hulumi/policies` | npm | All versions | 1.4.0 |

## How do I fix CVE-2026-48032?

Upgrade @hulumi/policies to 1.4.0 or later.

## Is CVE-2026-48032 being exploited?

There is no known exploitation of CVE-2026-48032 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48032 and fix it if it is affected.

What it is: CVE-2026-48032 is a high-severity authentication bypass vulnerability in kerberosmansour hulumi, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48032 in the wild and no public exploit code.

Affected packages and fixed versions:
- @hulumi/policies (npm): affected all versions; fixed in 1.4.0
- @hulumi/policies (npm): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48032/ (Markdown: https://insights.sbomify.com/CVE-2026-48032/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48032
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48032
- OSV: https://osv.dev/vulnerability/CVE-2026-48032

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48032/
Summaries are generated and may contain mistakes; the official description above is the record.
