# CVE-2026-48033: Hulumi: Policy packs bypassed by a forged Pulumi-URN logical name

> Attackers can bypass Hulumi policy packs by forging Pulumi-URN logical names, undermining infrastructure security controls.

- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jul 2026
- **Updated:** 24 Jul 2026
- **Also known as:** GHSA-rhgj-6g2c-frmm

## What is CVE-2026-48033?

CVE-2026-48033 is a high-severity vulnerability in kerberosmansour hulumi, published on 24 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Hulumi is an open-source toolkit that ships secure-by-default cloud and platform infrastructure components for Pulumi. Prior to version 1.4.0, policy packs can be bypassed by a forged Pulumi-URN logical name. This issue has been patched in version 1.4.0.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-48033?

2 open source packages ship an affected version, including @hulumi/policies.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@hulumi/policies` | npm | All versions | 1.4.0 |
| `@hulumi/policies` | npm | All versions | 1.4.0 |

## How do I fix CVE-2026-48033?

Upgrade @hulumi/policies to 1.4.0 or later.

## Is CVE-2026-48033 being exploited?

There is no known exploitation of CVE-2026-48033 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48033 and fix it if it is affected.

What it is: CVE-2026-48033 is a high-severity vulnerability in kerberosmansour hulumi, published on 24 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48033 in the wild and no public exploit code.

Affected packages and fixed versions:
- @hulumi/policies (npm): affected all versions; fixed in 1.4.0
- @hulumi/policies (npm): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48033/ (Markdown: https://insights.sbomify.com/CVE-2026-48033/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48033
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48033
- OSV: https://osv.dev/vulnerability/CVE-2026-48033

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48033/
Summaries are generated and may contain mistakes; the official description above is the record.
