# CVE-2026-48036: Hulumi: Drift classifier fails open on adapter errors and over-promotes Mixed verdicts

> Attackers can mask real infrastructure attacks or trigger false incidents by exploiting drift classifier failures in Hulumi, undermining security monitoring reliability.

- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:L/SC:N/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jul 2026
- **Updated:** 25 Jul 2026
- **Also known as:** GHSA-32g3-35g9-wc9g

## What is CVE-2026-48036?

CVE-2026-48036 is a high-severity vulnerability in kerberosmansour hulumi, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Hulumi is an open-source toolkit that ships secure-by-default cloud and platform infrastructure components for Pulumi. Prior to version 1.4.0, consumers running drift detection in CI / cron could see transient adapter failures silently cached as "all clear" — masking real attacks for up to six hours — or see ordinary provider-version churn falsely promoted to incident severity. Either way, the verdict source was unreliable for downstream incident workflows that gate on it. This issue has been patched in version 1.4.0.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2026-48036?

2 open source packages ship an affected version, including @hulumi/drift.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@hulumi/drift` | npm | All versions | 1.4.0 |
| `@hulumi/drift` | npm | All versions | 1.4.0 |

## How do I fix CVE-2026-48036?

Upgrade @hulumi/drift to 1.4.0 or later.

## Is CVE-2026-48036 being exploited?

There is no known exploitation of CVE-2026-48036 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48036 and fix it if it is affected.

What it is: CVE-2026-48036 is a high-severity vulnerability in kerberosmansour hulumi, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-48036 in the wild and no public exploit code.

Affected packages and fixed versions:
- @hulumi/drift (npm): affected all versions; fixed in 1.4.0
- @hulumi/drift (npm): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48036/ (Markdown: https://insights.sbomify.com/CVE-2026-48036/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48036
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48036
- OSV: https://osv.dev/vulnerability/CVE-2026-48036

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48036/
Summaries are generated and may contain mistakes; the official description above is the record.
