{"answers":{"affected":"4 open source packages ship an affected version, including joi.","exploited":"There is no known exploitation of CVE-2026-48038 in the wild and no public exploit code.","fix":"Upgrade joi to a fixed version for your release line: 17.13.4 or 18.2.1.","what":"CVE-2026-48038 is a medium-severity denial of service vulnerability in hapijs joi, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-48038 and fix it if it is affected.\n\nWhat it is: CVE-2026-48038 is a medium-severity denial of service vulnerability in hapijs joi, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-48038 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- joi (npm): affected all versions; fixed in 17.13.4\n- joi (npm): affected all versions; fixed in 17.13.4\n- joi (npm): affected from 18.0.0; fixed in 18.2.1\n- joi (npm): affected from 18.0.0; fixed in 18.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-48038/ (Markdown: https://insights.sbomify.com/CVE-2026-48038/index.md)","id":"CVE-2026-48038","markdown":"https://insights.sbomify.com/CVE-2026-48038/index.md","name":"CVE-2026-48038","record":{"aliases":["ECHO-0d17-e81d-14c0","GHSA-q7cg-457f-vx79","MINI-5v8g-7jgc-6cwp","MINI-63r3-m83j-4c6p","MINI-6chw-qq4v-2hfc","MINI-7ggx-hfcg-9v2g","MINI-7m8w-gvrv-xcmg","MINI-9274-6j5f-675v","MINI-92r9-989p-wfc9","MINI-9fg7-xwvx-vjc8","MINI-9g4w-65h2-jfqg","MINI-h6m2-6qpf-87j2","MINI-h7j2-g5ph-948j","MINI-j3vj-2qcx-944h","MINI-pvc9-x9v4-q993","MINI-vm7w-c5vx-78cg","MINI-w75r-r9w9-wqx3","MINI-wqqc-fxj4-7ff3","MINI-xxq4-53qr-pcpc","ROOT-APP-NPM-CVE-2026-48038"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript validation library","requires_auth":"none","summary":"Attackers can crash applications using the joi library by sending deeply nested input to recursive link schemas, causing an unhandled RangeError.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"joi is a schema description language and data validator for JavaScript. Prior to 17.13.4 and 18.2.1, denial of service is possible via an untrapped exception in services validating user-supplied JSON or object input with recursive link() schemas. When validate() is called without try/catch in a request handler, deeply nested input can trigger an unhandled RangeError and potentially crash the process; lower-impact paths using validateAsync() or try/catch produce a RangeError instead of a structured ValidationError. This issue is fixed in versions 17.13.4 and 18.2.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"joi: Uncaught RangeError on deeply nested input through recursive `link()` schemas","id":"CVE-2026-48038","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":4,"n_references":4,"next":{"headline":"Meta Ads MCP: Unauthenticated HTTP MCP Tool Execution Leaks Operator Meta Access Token","id":"CVE-2026-48039"},"packages":[{"ecosystem":"npm","fixed":["17.13.4"],"introduced":["0"],"last_affected":[],"package":"joi","purl":null,"source":"GHSA-q7cg-457f-vx79"},{"ecosystem":"npm","fixed":["17.13.4"],"introduced":["0"],"last_affected":[],"package":"joi","purl":"pkg:npm/joi","source":"GHSA-q7cg-457f-vx79"},{"ecosystem":"npm","fixed":["18.2.1"],"introduced":["18.0.0"],"last_affected":[],"package":"joi","purl":null,"source":"GHSA-q7cg-457f-vx79"},{"ecosystem":"npm","fixed":["18.2.1"],"introduced":["18.0.0"],"last_affected":[],"package":"joi","purl":"pkg:npm/joi","source":"GHSA-q7cg-457f-vx79"}],"prev":{"headline":"Hulumi: AccountFoundation reuse paths silently downgrade GuardDuty / Security Hub posture","id":"CVE-2026-48037"},"products":["joi"],"published":"2026-07-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["hapijs"]},"summary":"Attackers can crash applications using the joi library by sending deeply nested input to recursive link schemas, causing an unhandled RangeError.","url":"https://insights.sbomify.com/CVE-2026-48038/"}