CVE-2026-48042 Envoy: Stack overflow in destructor of highly nested JSON
Attackers can cause a stack overflow and crash the Envoy proxy by sending deeply nested JSON objects, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-48042?
CVE-2026-48042 is a high-severity denial of service vulnerability in Envoyproxy Envoy, published on 26 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to 1.35.11, 1.36.7, 1.37.3, and 1.38.1, destructor of JSON Object results in stack overflow when deeply O(100K) nested objects are present. This vulnerability is fixed in 1.35.11, 1.36.7, 1.37.3, and 1.38.1.
Weakness: CWE-1124
Which versions are affected by CVE-2026-48042?
1 open source package ship an affected version, including envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
envoy Bitnami | All versions | 1.35.11, 1.36.7, 1.37.3, 1.38.1 |
Products include Envoyproxy Envoy.
How do I fix CVE-2026-48042?
Upgrade envoy to a fixed version for your release line: 1.35.11, 1.36.7, 1.37.3 or 1.38.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-48042 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48042 exists.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2026-48042, GHSA-f24p-rxw2-g6pv.