# CVE-2026-48042: Envoy: Stack overflow in destructor of highly nested JSON

> Attackers can cause a stack overflow and crash the Envoy proxy by sending deeply nested JSON objects, requiring an upgrade to patched versions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2026
- **Updated:** 29 Jun 2026
- **Also known as:** BIT-envoy-2026-48042, GHSA-f24p-rxw2-g6pv

## What is CVE-2026-48042?

CVE-2026-48042 is a high-severity denial of service vulnerability in Envoyproxy Envoy, published on 26 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to 1.35.11, 1.36.7, 1.37.3, and 1.38.1, destructor of JSON Object results in stack overflow when deeply O(100K) nested objects are present. This vulnerability is fixed in 1.35.11, 1.36.7, 1.37.3, and 1.38.1.

Weakness: CWE-1124 (Excessively Deep Nesting)

## Which versions are affected by CVE-2026-48042?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | All versions | 1.35.11, 1.36.7, 1.37.3, 1.38.1 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2026-48042?

Upgrade envoy to a fixed version for your release line: 1.35.11, 1.36.7, 1.37.3 or 1.38.1.

## Is CVE-2026-48042 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48042 exists.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48042 and fix it if it is affected.

What it is: CVE-2026-48042 is a high-severity denial of service vulnerability in Envoyproxy Envoy, published on 26 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48042 exists.

Affected packages and fixed versions:
- envoy (Bitnami): affected all versions; fixed in 1.35.11, 1.36.7, 1.37.3, 1.38.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48042/ (Markdown: https://insights.sbomify.com/CVE-2026-48042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48042
- OSV: https://osv.dev/vulnerability/CVE-2026-48042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48042/
Summaries are generated and may contain mistakes; the official description above is the record.
