# CVE-2026-48047: XWiki Platform vulnerable to potential arbitrary file writing using path traversal from (subwiki) admin

> A subwiki admin can install a malicious WebJar extension to write arbitrary files via path traversal, potentially overriding configurations or resetting the superadmin password.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** GHSA-vgwr-23fq-pr7g

## What is CVE-2026-48047?

CVE-2026-48047 is a medium-severity path traversal vulnerability in xwiki-platform, published on 7 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

XWiki Platform WebJars API is a package for XWiki, a generic wiki platform. Starting with version 9.6-rc-1 and prior to versions 16.10.17, 17.4.9, and 17.10.3, a potential path traversal vulnerability allow an attacker who manages to get a malicious WebJar extension installed on the wiki to write arbitrary files. While the consequences could be severe like overriding configuration files and setting the superadmin password, the attack first requires that the attacker already has admin access to at least a subwiki to be able to install a malicious extension. Further, the attacker needs to publish a malicious extension in an extension repository that is configured in the instance. This vulnerability has been patched in XWiki 16.10.17, 17.4.9, 17.10.3, and 18.0.0RC1. XWiki is not aware of any workarounds except for being careful whom developers grant script and admin rights to.

Weakness: CWE-24 (Path Traversal: '../filedir')

## Which versions are affected by CVE-2026-48047?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-webjars-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-webjars-api` | Maven | From 17.0.0-rc-1 | 17.4.9 |
| `org.xwiki.platform:xwiki-platform-webjars-api` | Maven | From 17.0.0-rc-1 | 17.4.9 |
| `org.xwiki.platform:xwiki-platform-webjars-api` | Maven | From 17.5.0-rc-1 | 17.10.3 |
| `org.xwiki.platform:xwiki-platform-webjars-api` | Maven | From 17.5.0-rc-1 | 17.10.3 |
| `org.xwiki.platform:xwiki-platform-webjars-api` | Maven | From 9.6-rc-1 | 16.10.17 |
| `org.xwiki.platform:xwiki-platform-webjars-api` | Maven | From 9.6-rc-1 | 16.10.17 |

## How do I fix CVE-2026-48047?

Upgrade org.xwiki.platform:xwiki-platform-webjars-api to a fixed version for your release line: 17.4.9, 17.10.3 or 16.10.17.

## Is CVE-2026-48047 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48047 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48047 and fix it if it is affected.

What it is: CVE-2026-48047 is a medium-severity path traversal vulnerability in xwiki-platform, published on 7 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48047 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-webjars-api (Maven): affected from 17.0.0-rc-1; fixed in 17.4.9
- org.xwiki.platform:xwiki-platform-webjars-api (Maven): affected from 17.0.0-rc-1; fixed in 17.4.9
- org.xwiki.platform:xwiki-platform-webjars-api (Maven): affected from 17.5.0-rc-1; fixed in 17.10.3
- org.xwiki.platform:xwiki-platform-webjars-api (Maven): affected from 17.5.0-rc-1; fixed in 17.10.3
- org.xwiki.platform:xwiki-platform-webjars-api (Maven): affected from 9.6-rc-1; fixed in 16.10.17
- org.xwiki.platform:xwiki-platform-webjars-api (Maven): affected from 9.6-rc-1; fixed in 16.10.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48047/ (Markdown: https://insights.sbomify.com/CVE-2026-48047/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48047
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48047
- OSV: https://osv.dev/vulnerability/CVE-2026-48047

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48047/
Summaries are generated and may contain mistakes; the official description above is the record.
