# CVE-2026-48053: Kolibri has Unauthenticated Server-Side Request Forgery (SSRF) in RemoteFacilityUserViewset

> Unauthenticated attackers can exploit SSRF in Kolibri to fetch arbitrary URLs and read response data via vulnerable API endpoints.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-4mj9-pf4r-cqrc, PYSEC-2026-2554

## What is CVE-2026-48053?

CVE-2026-48053 is a medium-severity server-side request forgery vulnerability in learningequality kolibri, published on 17 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kolibri is an offline-first education platform. Prior to version 0.19.4, several Kolibri API endpoints accept an unvalidated `baseurl` parameter and fetch attacker-controlled URLs from the Kolibri server, reflecting the response body back to the caller. The original report identified two endpoints on the `RemoteFacilityUser*` viewsets; remediation review found two further reflection points on the same pattern. The GET endpoint was unauthenticated. Version 0.19.4 fixes the vulnerability.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-48053?

3 open source packages ship an affected version, including kolibri.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kolibri` | PyPI | All versions | 0.19.4 |
| `kolibri` | PyPI | All versions | 0.19.4 |
| `kolibri` | PyPI | All versions | 0.19.4 |

## How do I fix CVE-2026-48053?

Upgrade kolibri to 0.19.4 or later.

## Is CVE-2026-48053 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48053 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48053 and fix it if it is affected.

What it is: CVE-2026-48053 is a medium-severity server-side request forgery vulnerability in learningequality kolibri, published on 17 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48053 exists.

Affected packages and fixed versions:
- kolibri (PyPI): affected all versions; fixed in 0.19.4
- kolibri (PyPI): affected all versions; fixed in 0.19.4
- kolibri (PyPI): affected all versions; fixed in 0.19.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48053/ (Markdown: https://insights.sbomify.com/CVE-2026-48053/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48053
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48053
- OSV: https://osv.dev/vulnerability/CVE-2026-48053

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48053/
Summaries are generated and may contain mistakes; the official description above is the record.
