# CVE-2026-48060: Litestar: HTML Injection Through CSRF Token

> Attackers can inject HTML or scripts via CSRF tokens in Litestar apps using template engines, potentially leading to XSS and account takeover.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** GHSA-542p-wvx7-72m4, PYSEC-2026-2604

## What is CVE-2026-48060?

CVE-2026-48060 is a high-severity cross-site scripting vulnerability in litestar-org litestar, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Litestar is an Asynchronous Server Gateway Interface (ASGI) framework. Prior to version 2.20.0, Litestar instances which use a template engine in conjunction with CSRF protection are vulnerable to HTML Injection which can be escalated to Cross Site Scripting due to the contents of the CSRF cookie being excluded from automatic escaping by the template engine when configured inline with documentation recommendations. This issue has been patched in version 2.20.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-48060?

3 open source packages ship an affected version, including litestar.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litestar` | PyPI | All versions | 2.22.0 |
| `litestar` | PyPI | All versions | 2.22.0 |
| `litestar` | PyPI | All versions | 2.22.0 |

## How do I fix CVE-2026-48060?

Upgrade litestar to 2.22.0 or later.

## Is CVE-2026-48060 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48060 exists.

Public exploit code:

- https://github.com/Blinky-Keys/CVE-2026-48060 (github_poc): https://github.com/Blinky-Keys/CVE-2026-48060

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48060 and fix it if it is affected.

What it is: CVE-2026-48060 is a high-severity cross-site scripting vulnerability in litestar-org litestar, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48060 exists.

Affected packages and fixed versions:
- litestar (PyPI): affected all versions; fixed in 2.22.0
- litestar (PyPI): affected all versions; fixed in 2.22.0
- litestar (PyPI): affected all versions; fixed in 2.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48060/ (Markdown: https://insights.sbomify.com/CVE-2026-48060/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48060
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48060
- OSV: https://osv.dev/vulnerability/CVE-2026-48060

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48060/
Summaries are generated and may contain mistakes; the official description above is the record.
