{"answers":{"affected":"2 open source packages ship an affected version, including codeigniter4/framework.","exploited":"There is no known exploitation of CVE-2026-48062 in the wild and no public exploit code.","fix":"Upgrade codeigniter4/framework to 4.7.3 or later.","what":"CVE-2026-48062 is a critical vulnerability in CodeIgniter4, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-48062 and fix it if it is affected.\n\nWhat it is: CVE-2026-48062 is a critical vulnerability in CodeIgniter4, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-48062 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.7.3\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.7.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-48062/ (Markdown: https://insights.sbomify.com/CVE-2026-48062/index.md)","id":"CVE-2026-48062","markdown":"https://insights.sbomify.com/CVE-2026-48062/index.md","name":"CVE-2026-48062","record":{"aliases":["GHSA-2gr4-ppc7-7mhx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP web framework","requires_auth":"none","summary":"Attackers can upload malicious PHP files disguised as images to achieve arbitrary code execution if the application uses specific upload validation rules and stores files in web-accessible directories.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"CodeIgniter is a PHP full-stack web framework. Prior to 4.7.3, the ext_in upload validation rule in system/Validation/StrictRules/FileRules.php checked the MIME-derived guessed extension instead of the client-provided filename extension. As a result, an uploaded file named shell.php containing GIF-like content could pass validation such as uploaded[avatar]|is_image[avatar]|mime_in[avatar,image/gif]|ext_in[avatar,gif] because the detected MIME type maps to gif, even though the uploaded filename extension is php. Applications are impacted if they accept user-controlled uploads, rely on ext_in to validate the uploaded filename extension, save uploaded files using the original client filename with $file-\u003emove($path), store uploads in a web-accessible directory, and allow PHP or other executable files to run from that directory. In those conditions, this may lead to arbitrary code execution. This issue is fixed in version 4.7.3.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CodeIgniter: Uploaded file extension validation bypass in `ext_in` rule","id":"CVE-2026-48062","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"file_upload","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Baileys has message upsert / hist sync spoofing and app state corruption when using maliciously crafted protocolMessage payload","id":"CVE-2026-48063"},"packages":[{"ecosystem":"Packagist","fixed":["4.7.3"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":null,"source":"GHSA-2gr4-ppc7-7mhx"},{"ecosystem":"Packagist","fixed":["4.7.3"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":"pkg:composer/codeigniter4/framework","source":"GHSA-2gr4-ppc7-7mhx"}],"prev":{"headline":"Litestar: AllowedHostsMiddleware bypasses host validation via client-controlled X-Forwarded-Host header","id":"CVE-2026-48061"},"products":["CodeIgniter4"],"published":"2026-07-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-20","vendors":["codeigniter4"]},"summary":"Attackers can upload malicious PHP files disguised as images to achieve arbitrary code execution if the application uses specific upload validation rules and stores files in web-accessible directories.","url":"https://insights.sbomify.com/CVE-2026-48062/"}