# CVE-2026-48064: pam_usb: PAM_RHOST check skipped when deny_remote=false allows XDMCP authentication bypass

> Attackers can bypass remote authentication checks in pam_usb when deny_remote is disabled, allowing unauthorized access via XDMCP connections.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 May 2026
- **Updated:** 2 Jun 2026
- **Also known as:** GHSA-w38v-cw9r-x9p6

## What is CVE-2026-48064?

CVE-2026-48064 is a high-severity authentication bypass vulnerability in mcdope pam_usb, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pam_usb provides hardware authentication for Linux using ordinary removable media. Prior to 0.9.1, when a PAM service is configured with deny_remote=false in pam_usb (commonly done for display managers such as gdm-password or lightdm to bypass process/TTY heuristics for local sessions), the PAM_RHOST check in pusb_do_auth() is also skipped. PAM_RHOST is set by remote daemons (sshd, XDMCP servers) to identify the remote client address. Because the check is gated inside if (opts.deny_remote), a genuine remote XDMCP connection reaches the USB device authentication step instead of being rejected. This vulnerability is fixed in 0.9.1.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-48064?


## How do I fix CVE-2026-48064?

No fix has been published for CVE-2026-48064 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-48064 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48064 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48064 and fix it if it is affected.

What it is: CVE-2026-48064 is a high-severity authentication bypass vulnerability in mcdope pam_usb, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48064 exists.

Affected product: mcdope pam_usb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48064/ (Markdown: https://insights.sbomify.com/CVE-2026-48064/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48064
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48064
- OSV: https://osv.dev/vulnerability/CVE-2026-48064

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48064/
Summaries are generated and may contain mistakes; the official description above is the record.
