# CVE-2026-48065: Integer overflow in pam usb

> An integer overflow in pam_usb allows heap-based buffer overflow on 32-bit Linux systems, potentially enabling code execution.

- **Severity:** Medium 6.7 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-24mw-m2vf-36vp

## What is CVE-2026-48065?

CVE-2026-48065 is a medium-severity vulnerability in mcdope pam_usb, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

pam_usb provides hardware authentication for Linux using ordinary removable media. Prior to 0.9.1, src/conf.c allocates heap memory proportional to n_devices, a count derived from libxml2 XPath evaluation of the config file, without first enforcing an upper bound. On 32-bit targets (armv7l, i686 -- both listed in the project Makefile), the multiplication n_devices * sizeof(t_pusb_device) wraps around size_t, causing xmalloc() to receive a very small size. Because xmalloc() only calls abort() on NULL return, a small-but-non-NULL allocation is accepted, and subsequent array writes overflow the heap. This vulnerability is fixed in 0.9.1.

Weakness: CWE-190 (Integer Overflow or Wraparound), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-48065?


## How do I fix CVE-2026-48065?

No fix has been published for CVE-2026-48065 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-48065 being exploited?

There is no known exploitation of CVE-2026-48065 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48065 and fix it if it is affected.

What it is: CVE-2026-48065 is a medium-severity vulnerability in mcdope pam_usb, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48065 in the wild and no public exploit code.

Affected product: mcdope pam_usb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48065/ (Markdown: https://insights.sbomify.com/CVE-2026-48065/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48065
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48065
- OSV: https://osv.dev/vulnerability/CVE-2026-48065

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48065/
Summaries are generated and may contain mistakes; the official description above is the record.
