# CVE-2026-48068: @grpc/grps-js: A malformed request can cause a server crash

> A malformed HTTP/2 stream initiation can crash servers using the gRPC JavaScript library, requiring an upgrade to patched versions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 21 Jul 2026
- **Also known as:** CLEANSTART-2026-WU01571, ECHO-af19-5866-985c, GHSA-5375-pq7m-f5r2, MINI-3vh8-g2vw-q7wj, MINI-46cg-q95v-8r6p, MINI-5mf2-f6qh-3x6v, MINI-6429-hpvg-3rwg, MINI-6r45-7wq5-hcvp, MINI-843v-pc77-w377, MINI-8jw9-g3wp-7r85, MINI-8mcm-392h-7qjf, MINI-c4f6-2g8q-mxgp, MINI-f8hh-754w-q595, MINI-f94w-2j92-h9h4, MINI-f97h-r9gq-54j2, MINI-fhxj-cm9c-v8v7, MINI-fqm5-458p-fpfx, MINI-g2j9-8vrh-g3x6, MINI-gwqf-x3hp-fxcg, MINI-hxg4-fjcp-5vc6, MINI-m2cj-v5c7-43cj, MINI-mj8v-qfcg-32ch, ROOT-APP-NPM-CVE-2026-48068

## What is CVE-2026-48068?

CVE-2026-48068 is a high-severity denial of service vulnerability in grpc-node, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4, an invalid incoming HTTP/2 stream initiation can cause a server process created using @grpc/grpc-js to crash. This issue is fixed in versions 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-48068?

12 open source packages ship an affected version, including @grpc/grpc-js.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@grpc/grpc-js` | npm | All versions | 1.9.16 |
| `@grpc/grpc-js` | npm | All versions | 1.9.16 |
| `@grpc/grpc-js` | npm | From 1.10.0 | 1.10.12 |
| `@grpc/grpc-js` | npm | From 1.10.0 | 1.10.12 |
| `@grpc/grpc-js` | npm | From 1.11.0 | 1.11.4 |
| `@grpc/grpc-js` | npm | From 1.11.0 | 1.11.4 |
| `@grpc/grpc-js` | npm | From 1.12.0 | 1.12.7 |
| `@grpc/grpc-js` | npm | From 1.12.0 | 1.12.7 |
| `@grpc/grpc-js` | npm | From 1.13.0 | 1.13.5 |
| `@grpc/grpc-js` | npm | From 1.13.0 | 1.13.5 |
| `@grpc/grpc-js` | npm | From 1.14.0 | 1.14.4 |
| `@grpc/grpc-js` | npm | From 1.14.0 | 1.14.4 |

## How do I fix CVE-2026-48068?

Upgrade @grpc/grpc-js to a fixed version for your release line: 1.9.16, 1.10.12, 1.11.4 or 1.12.7.

## Is CVE-2026-48068 being exploited?

There is no known exploitation of CVE-2026-48068 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48068 and fix it if it is affected.

What it is: CVE-2026-48068 is a high-severity denial of service vulnerability in grpc-node, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48068 in the wild and no public exploit code.

Affected packages and fixed versions:
- @grpc/grpc-js (npm): affected all versions; fixed in 1.9.16
- @grpc/grpc-js (npm): affected all versions; fixed in 1.9.16
- @grpc/grpc-js (npm): affected from 1.10.0; fixed in 1.10.12
- @grpc/grpc-js (npm): affected from 1.10.0; fixed in 1.10.12
- @grpc/grpc-js (npm): affected from 1.11.0; fixed in 1.11.4
- @grpc/grpc-js (npm): affected from 1.11.0; fixed in 1.11.4
- @grpc/grpc-js (npm): affected from 1.12.0; fixed in 1.12.7
- @grpc/grpc-js (npm): affected from 1.12.0; fixed in 1.12.7
- @grpc/grpc-js (npm): affected from 1.13.0; fixed in 1.13.5
- @grpc/grpc-js (npm): affected from 1.13.0; fixed in 1.13.5
- @grpc/grpc-js (npm): affected from 1.14.0; fixed in 1.14.4
- @grpc/grpc-js (npm): affected from 1.14.0; fixed in 1.14.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48068/ (Markdown: https://insights.sbomify.com/CVE-2026-48068/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48068
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48068
- OSV: https://osv.dev/vulnerability/CVE-2026-48068

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48068/
Summaries are generated and may contain mistakes; the official description above is the record.
