# CVE-2026-48070: Docmost: Avatar URL path traversal in avatar cleanup leads to arbitrary local file deletion

> Authenticated users can delete arbitrary local files via path traversal in avatar cleanup on local-storage deployments.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Sep 2026
- **Updated:** 5 Oct 2026
- **Also known as:** GHSA-95f8-h5hf-8248

## What is CVE-2026-48070?

CVE-2026-48070 is a high-severity path traversal vulnerability in docmost, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Docmost is open-source collaborative wiki and documentation software. Prior to 0.80.1, authenticated users can store attacker-controlled avatarUrl values that are later reused by avatar cleanup without confinement to the intended directory on local-storage deployments. A low-privileged user can cause deletion of arbitrary local files or directories reachable by the Docmost service account. This issue is fixed in version 0.80.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-48070?


## How do I fix CVE-2026-48070?

No fix has been published for CVE-2026-48070 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-48070 being exploited?

There is no known exploitation of CVE-2026-48070 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48070 and fix it if it is affected.

What it is: CVE-2026-48070 is a high-severity path traversal vulnerability in docmost, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48070 in the wild and no public exploit code.

Affected product: docmost. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48070/ (Markdown: https://insights.sbomify.com/CVE-2026-48070/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48070
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48070
- OSV: https://osv.dev/vulnerability/CVE-2026-48070

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48070/
Summaries are generated and may contain mistakes; the official description above is the record.
