# CVE-2026-48089: DevGuard has improper authorization on public assets

> Authenticated users can modify vulnerability data on public assets without proper authorization, requiring a patch or configuration change.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-6p54-fw2f-q7gf, GO-2026-5183

## What is CVE-2026-48089?

CVE-2026-48089 is a high-severity missing authorization vulnerability in l3montree-dev devguard, published on 19 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

DevGuard provides vulnerability management for the full software supply chain. Prior to 1.4.2, on a DevGuard API instance with one or more public assets, any authenticated user — including users from a different organization with no membership or role in the affected org/project — can create, update, reapply, and delete VEX rules on those public assets. The same flaw affects the other vulnerability-triage write endpoints exposed under a public asset, including VEX rule create / update / reapply / delete; dependency-vuln event creation (accept / reject / mitigate decisions), batch event creation, vuln sync, and mitigation; license risk creation; external reference writes; and/or artifact creation and license refresh. The attacker needs a valid account on the instance, but no membership in the victim organization, project, or asset is required. Version `v1.4.2`contains a patch. As a workaround, make affected assets non-public. In the asset settings, switch visibility from public to private. This removes the public-read exemption in the access-control middleware and restores correct authorization on all write endpoints for that asset. Downstream consumers that previously relied on the public `vex.json` / `sbom.json` endpoints will need to be granted explicit access or must receive an exported file version until the patched release is deployed.

Weakness: CWE-863 (Incorrect Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-48089?

3 open source packages ship an affected version, including github.com/l3montree-dev/devguard.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/l3montree-dev/devguard` | Go | All versions | 1.4.2 |
| `github.com/l3montree-dev/devguard` | Go | All versions | 1.4.2 |
| `github.com/l3montree-dev/devguard` | Go | All versions | 1.4.2 |

## How do I fix CVE-2026-48089?

Upgrade github.com/l3montree-dev/devguard to 1.4.2 or later.

## Is CVE-2026-48089 being exploited?

There is no known exploitation of CVE-2026-48089 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48089 and fix it if it is affected.

What it is: CVE-2026-48089 is a high-severity missing authorization vulnerability in l3montree-dev devguard, published on 19 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48089 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/l3montree-dev/devguard (Go): affected all versions; fixed in 1.4.2
- github.com/l3montree-dev/devguard (Go): affected all versions; fixed in 1.4.2
- github.com/l3montree-dev/devguard (Go): affected all versions; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48089/ (Markdown: https://insights.sbomify.com/CVE-2026-48089/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48089
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48089
- OSV: https://osv.dev/vulnerability/CVE-2026-48089

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48089/
Summaries are generated and may contain mistakes; the official description above is the record.
