{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48093 exists.","fix":"No fix has been published for CVE-2026-48093 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-48093 is a medium-severity cross-site scripting vulnerability in dartiss code-embed, published on 7 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-48093 and fix it if it is affected.\n\nWhat it is: CVE-2026-48093 is a medium-severity cross-site scripting vulnerability in dartiss code-embed, published on 7 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48093 exists.\n\nAffected product: dartiss code-embed. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-48093/ (Markdown: https://insights.sbomify.com/CVE-2026-48093/index.md)","id":"CVE-2026-48093","markdown":"https://insights.sbomify.com/CVE-2026-48093/index.md","name":"CVE-2026-48093","record":{"aliases":["GHSA-7c9x-px5v-5hcp"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Contributors can inject JavaScript via remote URL embeds, executing code when administrators preview posts, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Code Embed WordPress plugin prior to version 2.6.1 is vulnerable to stored Cross-Site Scripting (XSS) through the external URL embed feature in post content. The vulnerable code scans rendered content for URL embed tokens, fetches the remote URL, and inserts the remote response body into the page without output sanitization or an `unfiltered_html` capability check. This allows a Contributor attacker to submit a pending post containing an inert-looking URL token that executes attacker-controlled JavaScript when an Administrator or Editor previews or reviews the post. This is distinct from CVE-2026-2512, which affected custom field meta values up to version 2.5.1. This vector affects version 2.6 and uses the documented external URL embed feature in post content. This particular issue is patched in version 2.6.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Code Embed - Contributor Stored Cross-Site Scripting via Remote URL Embed","id":"CVE-2026-48093","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"ShareOpenly has Cross-Site Scripting (XSS) via Missing esc_url() on Shared URL in Content Output","id":"CVE-2026-48094"},"packages":[],"prev":{"headline":"7-Zip SquashFS Fragment Offset Overflow (GHSL-2026-116)","id":"CVE-2026-48092"},"products":["code-embed"],"published":"2026-08-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-10","vendors":["dartiss"]},"summary":"Contributors can inject JavaScript via remote URL embeds, executing code when administrators preview posts, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2026-48093/"}