# CVE-2026-48093: Code Embed - Contributor Stored Cross-Site Scripting via Remote URL Embed

> Contributors can inject JavaScript via remote URL embeds, executing code when administrators preview posts, potentially leading to account takeover.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 7 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** GHSA-7c9x-px5v-5hcp

## What is CVE-2026-48093?

CVE-2026-48093 is a medium-severity cross-site scripting vulnerability in dartiss code-embed, published on 7 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Code Embed WordPress plugin prior to version 2.6.1 is vulnerable to stored Cross-Site Scripting (XSS) through the external URL embed feature in post content. The vulnerable code scans rendered content for URL embed tokens, fetches the remote URL, and inserts the remote response body into the page without output sanitization or an `unfiltered_html` capability check. This allows a Contributor attacker to submit a pending post containing an inert-looking URL token that executes attacker-controlled JavaScript when an Administrator or Editor previews or reviews the post. This is distinct from CVE-2026-2512, which affected custom field meta values up to version 2.5.1. This vector affects version 2.6 and uses the documented external URL embed feature in post content. This particular issue is patched in version 2.6.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-48093?


## How do I fix CVE-2026-48093?

No fix has been published for CVE-2026-48093 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-48093 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48093 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48093 and fix it if it is affected.

What it is: CVE-2026-48093 is a medium-severity cross-site scripting vulnerability in dartiss code-embed, published on 7 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48093 exists.

Affected product: dartiss code-embed. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48093/ (Markdown: https://insights.sbomify.com/CVE-2026-48093/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48093
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48093
- OSV: https://osv.dev/vulnerability/CVE-2026-48093

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48093/
Summaries are generated and may contain mistakes; the official description above is the record.
