# CVE-2026-48096: OpenFGA has cache-key delimiter injection in shared-iterator and v2 iterator that caches enables intra-store authorization-decision poisoning

> Attackers can poison authorization caches by injecting delimiters, causing incorrect permission decisions when iterator caching is enabled.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 10 Jun 2026
- **Also known as:** CLEANSTART-2026-CD29360, CLEANSTART-2026-FA26777, CLEANSTART-2026-IC81129, CLEANSTART-2026-OZ34344, ECHO-91cb-53c9-355e, GHSA-8396-jffm-qx4w, GO-2026-5239, MINI-377p-rvx4-jx9m, MINI-3hjf-2rqr-p3m9, MINI-3qfh-6pvj-2xjx, MINI-69g8-qgx9-7pmw, MINI-893c-57fg-rmfj, MINI-9694-9q5j-ghpx, MINI-9fr7-xwg7-jphm, MINI-c2jv-pqvw-qvc4, MINI-f2mq-j6c3-mh59, MINI-f6vm-c2vg-cfm6, MINI-fvx5-w52g-v57f, MINI-fwvx-pq96-c6r8, MINI-mgm5-xq2j-3h6f, MINI-rq67-4g4v-rxcf, MINI-vh8w-x4p3-h7vc, MINI-vq62-47x5-8xrc, MINI-vw3p-qp65-q79v, MINI-x534-xwp2-hw4h, MINI-x56f-hmqh-38w5

## What is CVE-2026-48096?

CVE-2026-48096 is a medium-severity vulnerability in openfga, published on 10 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenFGA is an authorization/permission engine built for developers. Prior to version 1.16.0, when iterator caching is enabled, two distinct check requests can produce the same cache key, leading to OpenFGA reusing an earlier cached result for a subsequent request. This issue has been patched in version 1.16.0.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-48096?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | All versions | 1.16.0 |
| `github.com/openfga/openfga` | Go | All versions | 1.16.0 |
| `github.com/openfga/openfga` | Go | All versions | 1.16.0 |

Products: Openfga Helm Charts, Openfga Openfga.

## How do I fix CVE-2026-48096?

Upgrade github.com/openfga/openfga to 1.16.0 or later.

## Is CVE-2026-48096 being exploited?

There is no known exploitation of CVE-2026-48096 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2026-55689](https://insights.sbomify.com/CVE-2026-55689/): OpenFGA: OIDC audience validation skipped when --authn-oidc-audience is unset (medium 6.8)
- [CVE-2026-24851](https://insights.sbomify.com/CVE-2026-24851/): OpenFGA Improper Policy Enforcement (medium 5.8)
- [CVE-2025-64751](https://insights.sbomify.com/CVE-2025-64751/): OpenFGA Improper Policy Enforcement (medium 5.8)
- [CVE-2025-55213](https://insights.sbomify.com/CVE-2025-55213/): OpenFGA Authorization Bypass (Check) (medium 5.8)
- [CVE-2025-48371](https://insights.sbomify.com/CVE-2025-48371/): OpenFGA Authorization Bypass (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48096 and fix it if it is affected.

What it is: CVE-2026-48096 is a medium-severity vulnerability in openfga, published on 10 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48096 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.16.0
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.16.0
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48096/ (Markdown: https://insights.sbomify.com/CVE-2026-48096/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48096
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48096
- OSV: https://osv.dev/vulnerability/CVE-2026-48096

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48096/
Summaries are generated and may contain mistakes; the official description above is the record.
