{"answers":{"affected":"3 open source packages ship an affected version, including wsgidav.","exploited":"There is no known exploitation of CVE-2026-48099 in the wild and no public exploit code.","fix":"Upgrade wsgidav to 4.3.4 or later.","what":"CVE-2026-48099 is a high-severity path traversal vulnerability in mar10 wsgidav, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-48099 and fix it if it is affected.\n\nWhat it is: CVE-2026-48099 is a high-severity path traversal vulnerability in mar10 wsgidav, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-48099 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wsgidav (PyPI): affected all versions; fixed in 4.3.4\n- wsgidav (PyPI): affected all versions; fixed in 4.3.4\n- wsgidav (PyPI): affected all versions; fixed in 4.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-48099/ (Markdown: https://insights.sbomify.com/CVE-2026-48099/index.md)","id":"CVE-2026-48099","markdown":"https://insights.sbomify.com/CVE-2026-48099/index.md","name":"CVE-2026-48099","record":{"aliases":["GHSA-wxq4-cc2q-338q","PYSEC-2026-3428"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WebDAV server","requires_auth":"low_privilege","summary":"Attackers can escape the configured filesystem share root via encoded dot segments in WebDAV requests, potentially reading or modifying unauthorized files.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"WsgiDAV is a generic and extendable WebDAV server based on WSGI. WsgiDAV 4.3.3 and prior can allow a WebDAV request path containing an encoded parent-directory segment to escape the configured filesystem share root in a specific path layout. The issue is fixed with version 4.3.4.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WsgiDAV encoded dot segments can escape filesystem share roots","id":"CVE-2026-48099","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Payy: agg_agg trailing message slots are unconstrained and allow forged burn messages","id":"CVE-2026-48100"},"packages":[{"ecosystem":"PyPI","fixed":["4.3.4"],"introduced":["0"],"last_affected":[],"package":"wsgidav","purl":null,"source":"GHSA-wxq4-cc2q-338q"},{"ecosystem":"PyPI","fixed":["4.3.4"],"introduced":["0"],"last_affected":[],"package":"wsgidav","purl":"pkg:pypi/wsgidav","source":"GHSA-wxq4-cc2q-338q"},{"ecosystem":"PyPI","fixed":["4.3.4"],"introduced":["0"],"last_affected":[],"package":"wsgidav","purl":"pkg:pypi/wsgidav","source":"PYSEC-2026-3428"}],"prev":{"headline":"NexTOR IP Changer Unsafely Uses sudo and shell=True","id":"CVE-2026-48098"},"products":["wsgidav"],"published":"2026-08-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-14","vendors":["mar10"]},"summary":"Attackers can escape the configured filesystem share root via encoded dot segments in WebDAV requests, potentially reading or modifying unauthorized files.","url":"https://insights.sbomify.com/CVE-2026-48099/"}