# CVE-2026-48099: WsgiDAV encoded dot segments can escape filesystem share roots

> Attackers can escape the configured filesystem share root via encoded dot segments in WebDAV requests, potentially reading or modifying unauthorized files.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-wxq4-cc2q-338q, PYSEC-2026-3428

## What is CVE-2026-48099?

CVE-2026-48099 is a high-severity path traversal vulnerability in mar10 wsgidav, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

WsgiDAV is a generic and extendable WebDAV server based on WSGI. WsgiDAV 4.3.3 and prior can allow a WebDAV request path containing an encoded parent-directory segment to escape the configured filesystem share root in a specific path layout. The issue is fixed with version 4.3.4.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-48099?

3 open source packages ship an affected version, including wsgidav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wsgidav` | PyPI | All versions | 4.3.4 |
| `wsgidav` | PyPI | All versions | 4.3.4 |
| `wsgidav` | PyPI | All versions | 4.3.4 |

## How do I fix CVE-2026-48099?

Upgrade wsgidav to 4.3.4 or later.

## Is CVE-2026-48099 being exploited?

There is no known exploitation of CVE-2026-48099 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48099 and fix it if it is affected.

What it is: CVE-2026-48099 is a high-severity path traversal vulnerability in mar10 wsgidav, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48099 in the wild and no public exploit code.

Affected packages and fixed versions:
- wsgidav (PyPI): affected all versions; fixed in 4.3.4
- wsgidav (PyPI): affected all versions; fixed in 4.3.4
- wsgidav (PyPI): affected all versions; fixed in 4.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48099/ (Markdown: https://insights.sbomify.com/CVE-2026-48099/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48099
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48099
- OSV: https://osv.dev/vulnerability/CVE-2026-48099

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48099/
Summaries are generated and may contain mistakes; the official description above is the record.
