# CVE-2026-4810: Remote Code Execution in Google Agent Development Kit (ADK)

> Unauthenticated remote attackers can execute arbitrary code on servers hosting the Google Agent Development Kit due to missing authentication and code injection flaws.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2026
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-rg7c-g689-fr3x, PYSEC-2026-344

## What is CVE-2026-4810?

CVE-2026-4810 is a critical code injection vulnerability in Google Cloud Agent Development Kit (ADK), published on 13 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Code Injection and Missing Authentication vulnerability in Google Agent Development Kit (ADK) versions 1.7.0 (and 2.0.0a1) through 1.28.1 (and 2.0.0a2) on Python (OSS), Cloud Run, and GKE allows an unauthenticated remote attacker to execute arbitrary code on the server hosting the ADK instance.

This vulnerability was patched in versions 1.28.1 and 2.0.0a2.

Customers need to redeploy the upgraded ADK to their production environments. In addition, if they are running ADK Web locally, they also need to upgrade their local instance.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-4810?

5 open source packages ship an affected version, including google-adk.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `google-adk` | PyPI | From 1.7.0 | 1.28.1, 2.0.0a2 |
| `google-adk` | PyPI | From 1.7.0 | 1.28.1 |
| `google-adk` | PyPI | From 1.7.0 | 1.28.1 |
| `google-adk` | PyPI | From 2.0.0a1 | 2.0.0a2 |
| `google-adk` | PyPI | From 2.0.0a1 | 2.0.0a2 |

## How do I fix CVE-2026-4810?

Upgrade google-adk to a fixed version for your release line: 1.28.1 or 2.0.0a2.

## Is CVE-2026-4810 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4810 exists.

Public exploit code:

- Google ADK-Python - Unauthenticated Builder Endpoint (nuclei): http/cves/2026/CVE-2026-4810.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4810 and fix it if it is affected.

What it is: CVE-2026-4810 is a critical code injection vulnerability in Google Cloud Agent Development Kit (ADK), published on 13 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4810 exists.

Affected packages and fixed versions:
- google-adk (PyPI): affected from 1.7.0; fixed in 1.28.1, 2.0.0a2
- google-adk (PyPI): affected from 1.7.0; fixed in 1.28.1
- google-adk (PyPI): affected from 1.7.0; fixed in 1.28.1
- google-adk (PyPI): affected from 2.0.0a1; fixed in 2.0.0a2
- google-adk (PyPI): affected from 2.0.0a1; fixed in 2.0.0a2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4810/ (Markdown: https://insights.sbomify.com/CVE-2026-4810/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4810
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4810
- OSV: https://osv.dev/vulnerability/CVE-2026-4810

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4810/
Summaries are generated and may contain mistakes; the official description above is the record.
