{"answers":{"affected":"2 open source packages ship an affected version, including russh.","exploited":"There is no known exploitation of CVE-2026-48107 in the wild and no public exploit code.","fix":"Upgrade russh to 0.61.0 or later.","what":"CVE-2026-48107 is a medium-severity denial of service vulnerability in Eugeny russh, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-48107 and fix it if it is affected.\n\nWhat it is: CVE-2026-48107 is a medium-severity denial of service vulnerability in Eugeny russh, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-48107 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- russh (crates.io): affected from 0.37.0; fixed in 0.61.0\n- russh (crates.io): affected from 0.37.0; fixed in 0.61.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-48107/ (Markdown: https://insights.sbomify.com/CVE-2026-48107/index.md)","id":"CVE-2026-48107","markdown":"https://insights.sbomify.com/CVE-2026-48107/index.md","name":"CVE-2026-48107","record":{"aliases":["DEBIAN-CVE-2026-48107","GHSA-g9g7-5cgw-6v28"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust SSH library","requires_auth":"none","summary":"A malicious SSH server can cause a client crash by sending an excessive prompt count, leading to denial of service in the Russh library.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Russh is a Rust SSH client \u0026 server library. From version 0.37.0 to before version 0.61.0, in the russh client keyboard-interactive authentication path, a malicious SSH server could send a USERAUTH_INFO_REQUEST with an attacker-controlled prompt count, and the client would use that raw count directly in Vec::with_capacity(...) before validating that enough prompt data was actually present in the packet. This issue has been patched in version 0.61.0.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Russh: Unchecked keyboard-interactive prompt count in client auth path","id":"CVE-2026-48107","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Russh: SSH identification parsing accepted non-canonical client banners and did not bound pre-banner input","id":"CVE-2026-48108"},"packages":[{"ecosystem":"crates.io","fixed":["0.61.0"],"introduced":["0.37.0"],"last_affected":[],"package":"russh","purl":null,"source":"GHSA-g9g7-5cgw-6v28"},{"ecosystem":"crates.io","fixed":["0.61.0"],"introduced":["0.37.0"],"last_affected":[],"package":"russh","purl":"pkg:cargo/russh","source":"GHSA-g9g7-5cgw-6v28"}],"prev":{"headline":"Missing authorization in arc","id":"CVE-2026-48106"},"products":["russh"],"published":"2026-06-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-11","vendors":["Eugeny"]},"summary":"A malicious SSH server can cause a client crash by sending an excessive prompt count, leading to denial of service in the Russh library.","url":"https://insights.sbomify.com/CVE-2026-48107/"}