# CVE-2026-48108: Russh: SSH identification parsing accepted non-canonical client banners and did not bound pre-banner input

> Remote attackers can exhaust server resources during SSH connection setup by sending malformed identification strings, affecting applications using the russh library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-48108, GHSA-76r6-x97p-67vr

## What is CVE-2026-48108?

CVE-2026-48108 is a medium-severity denial of service vulnerability in Eugeny russh, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Russh is a Rust SSH client & server library. From version 0.34.0-beta.1 to before version 0.61.0, russh did not enforce the SSH identification-string rules as deliberately as OpenSSH. In particular, the server-side identification reader used the same permissive path as the client, allowing pre-banner lines from clients, and the reader did not enforce a bounded number of pre-banner lines. For a library server built on russh, this could allow a remote peer to hold connection setup resources in the cleartext pre-authentication phase with malformed identification input that should have been rejected early. This issue has been patched in version 0.61.0.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-48108?

2 open source packages ship an affected version, including russh.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `russh` | crates.io | From 0.34.0-beta.1 | 0.61.0 |
| `russh` | crates.io | From 0.34.0-beta.1 | 0.61.0 |

## How do I fix CVE-2026-48108?

Upgrade russh to 0.61.0 or later.

## Is CVE-2026-48108 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48108 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48108 and fix it if it is affected.

What it is: CVE-2026-48108 is a medium-severity denial of service vulnerability in Eugeny russh, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48108 exists.

Affected packages and fixed versions:
- russh (crates.io): affected from 0.34.0-beta.1; fixed in 0.61.0
- russh (crates.io): affected from 0.34.0-beta.1; fixed in 0.61.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48108/ (Markdown: https://insights.sbomify.com/CVE-2026-48108/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48108
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48108
- OSV: https://osv.dev/vulnerability/CVE-2026-48108

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48108/
Summaries are generated and may contain mistakes; the official description above is the record.
