# CVE-2026-48109: MessagePack-CSharp: LZ4 decompression may fail with AccessViolationException after dereferencing memory from bad input

> A remote attacker can cause denial of service and potential memory disclosure in MessagePack-CSharp by sending crafted payloads to the optional LZ4 decompression path.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** ECHO-664b-126f-78fd, GHSA-hv8m-jj95-wg3x, MINI-2m69-gr77-5447

## What is CVE-2026-48109?

CVE-2026-48109 is a high-severity memory corruption vulnerability in MessagePack-CSharp, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MessagePack for C# is a MessagePack serializer for C#. Prior to 2.5.301 and 3.1.7, A vulnerability exists in the optional LZ4 decompression path used by MessagePack compression modes Lz4Block and Lz4BlockArray. The decoder implementation is based on a deprecated fast-decompression algorithm that does not take a source-length bound. A remote attacker can send a crafted MessagePack payload with manipulated LZ4 token/length fields to force out-of-bounds reads from the compressed input buffer. In affected environments, this can trigger an AccessViolationException during decompression, causing process termination (denial of service). Under some conditions, limited unintended memory disclosure from over-read data may also be possible before failure. This vulnerability is fixed in 2.5.301 and 3.1.7.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-48109?

4 open source packages ship an affected version, including MessagePack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `MessagePack` | NuGet | All versions | 2.5.301 |
| `MessagePack` | NuGet | All versions | 2.5.301 |
| `MessagePack` | NuGet | From 3.0.214-rc.1 | 3.1.7 |
| `MessagePack` | NuGet | From 3.0.214-rc.1 | 3.1.7 |

Products: Messagepack Messagepack.

## How do I fix CVE-2026-48109?

Upgrade MessagePack to a fixed version for your release line: 2.5.301 or 3.1.7.

## Is CVE-2026-48109 being exploited?

There is no known exploitation of CVE-2026-48109 in the wild and no public exploit code.

## Other vulnerabilities in MessagePack-CSharp

- [CVE-2026-48502](https://insights.sbomify.com/CVE-2026-48502/): MessagePack-CSharp: Denial of service vulnerabilities can swamp the CPU or crash the process with stack and heap overflows (high 8.2)
- [CVE-2026-48506](https://insights.sbomify.com/CVE-2026-48506/): MessagePack-CSharp: MessagePackReader.Skip can recurse without enforcing maximum object graph depth (high 7.5)
- [CVE-2026-48509](https://insights.sbomify.com/CVE-2026-48509/): MessagePack-CSharp: ASP.NET Core MessagePackInputFormatter defaults to TrustedData for HTTP request bodies (medium 6.3)
- [CVE-2026-48510](https://insights.sbomify.com/CVE-2026-48510/): MessagePack-CSharp: LZ4 decompression allocates from unbounded declared output lengths (medium 6.3)
- [CVE-2026-48511](https://insights.sbomify.com/CVE-2026-48511/): MessagePack-CSharp: ExpandoObject formatter can perform quadratic insertion work on untrusted maps (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48109 and fix it if it is affected.

What it is: CVE-2026-48109 is a high-severity memory corruption vulnerability in MessagePack-CSharp, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48109 in the wild and no public exploit code.

Affected packages and fixed versions:
- MessagePack (NuGet): affected all versions; fixed in 2.5.301
- MessagePack (NuGet): affected all versions; fixed in 2.5.301
- MessagePack (NuGet): affected from 3.0.214-rc.1; fixed in 3.1.7
- MessagePack (NuGet): affected from 3.0.214-rc.1; fixed in 3.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48109/ (Markdown: https://insights.sbomify.com/CVE-2026-48109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48109
- OSV: https://osv.dev/vulnerability/CVE-2026-48109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48109/
Summaries are generated and may contain mistakes; the official description above is the record.
