CVE-2026-48110 Russh: SSH message fields were decoded through allocation-first parsers before field-specific bounds

High 7.5 Published Updated

Remote attackers can cause denial of service in Russh SSH library by sending malformed length-prefixed fields that trigger excessive memory allocation before validation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-48110?

CVE-2026-48110 is a high-severity denial of service vulnerability in Eugeny russh, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Russh is a Rust SSH client & server library. From version 0.34.0 to before version 0.61.0, several russh client and server message handlers decoded attacker-controlled SSH strings, name-lists, and byte fields into owned allocations before applying field-specific bounds. A remote SSH peer could send oversized, high-fanout, or malformed length-prefixed fields and make the library allocate, attempt to allocate, or split data before rejecting input that should have been rejected earlier. This issue has been patched in version 0.61.0.

Weakness: CWE-20

Which versions are affected by CVE-2026-48110?

2 open source packages ship an affected version, including russh.

PackageAffectedFixed in
russh crates.ioFrom 0.34.00.61.0
russh crates.ioFrom 0.34.00.61.0

How do I fix CVE-2026-48110?

Upgrade russh to 0.61.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-48110 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48110 exists.

Sources

Also known as DEBIAN-CVE-2026-48110, GHSA-4r3c-5hpg-58qr.

Is CVE-2026-48110 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free