{"answers":{"affected":"2 open source packages ship an affected version, including budibase.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48128 exists.","fix":"Upgrade budibase to 3.39.0 or later.","what":"CVE-2026-48128 is a medium-severity server-side request forgery vulnerability in budibase, published on 27 May 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-48128 and fix it if it is affected.\n\nWhat it is: CVE-2026-48128 is a medium-severity server-side request forgery vulnerability in budibase, published on 27 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48128 exists.\n\nAffected packages and fixed versions:\n- budibase (npm): affected all versions; fixed in 3.39.0\n- budibase (npm): affected all versions; fixed in 3.39.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-48128/ (Markdown: https://insights.sbomify.com/CVE-2026-48128/index.md)","id":"CVE-2026-48128","markdown":"https://insights.sbomify.com/CVE-2026-48128/index.md","name":"CVE-2026-48128","record":{"aliases":["GHSA-6964-pp88-6wp9"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Budibase low-code platform","requires_auth":"high_privilege","summary":"Attackers can exploit unvalidated query IDs in automations to force the server to make internal HTTP requests, exposing sensitive data from internal services.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Budibase is an open-source low-code platform. Prior to 3.39.0, the executeQuery automation step in Budibase accepts a queryId from automation step inputs and passes it directly to the query execution controller without additional validation. When combined with a REST datasource configured to target internal infrastructure, this creates a server-side request forgery path where automation execution causes the Budibase server to make outbound HTTP requests to attacker-influenced destinations. The automation output then returns the response, potentially exposing internal service data. This vulnerability is fixed in 3.39.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Budibase: SSRF via User-Controlled queryId in Automation Execute Query Step","id":"CVE-2026-48128","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Kestra task inputFiles accepts traversal filenames for worker file writes","id":"CVE-2026-48129"},"packages":[{"ecosystem":"npm","fixed":["3.39.0"],"introduced":["0"],"last_affected":[],"package":"budibase","purl":null,"source":"GHSA-6964-pp88-6wp9"},{"ecosystem":"npm","fixed":["3.39.0"],"introduced":["0"],"last_affected":[],"package":"budibase","purl":"pkg:npm/budibase","source":"GHSA-6964-pp88-6wp9"}],"prev":{"headline":"Frappe: Arbitrary Attachment Injection via add_attachments and upload_file","id":"CVE-2026-48127"},"products":["budibase"],"published":"2026-05-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-27","vendors":["Budibase"]},"summary":"Attackers can exploit unvalidated query IDs in automations to force the server to make internal HTTP requests, exposing sensitive data from internal services.","url":"https://insights.sbomify.com/CVE-2026-48128/"}