# CVE-2026-48128: Budibase: SSRF via User-Controlled queryId in Automation Execute Query Step

> Attackers can exploit unvalidated query IDs in automations to force the server to make internal HTTP requests, exposing sensitive data from internal services.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-6964-pp88-6wp9

## What is CVE-2026-48128?

CVE-2026-48128 is a medium-severity server-side request forgery vulnerability in budibase, published on 27 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.39.0, the executeQuery automation step in Budibase accepts a queryId from automation step inputs and passes it directly to the query execution controller without additional validation. When combined with a REST datasource configured to target internal infrastructure, this creates a server-side request forgery path where automation execution causes the Budibase server to make outbound HTTP requests to attacker-influenced destinations. The automation output then returns the response, potentially exposing internal service data. This vulnerability is fixed in 3.39.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-48128?

2 open source packages ship an affected version, including budibase.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `budibase` | npm | All versions | 3.39.0 |
| `budibase` | npm | All versions | 3.39.0 |

## How do I fix CVE-2026-48128?

Upgrade budibase to 3.39.0 or later.

## Is CVE-2026-48128 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48128 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48128 and fix it if it is affected.

What it is: CVE-2026-48128 is a medium-severity server-side request forgery vulnerability in budibase, published on 27 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48128 exists.

Affected packages and fixed versions:
- budibase (npm): affected all versions; fixed in 3.39.0
- budibase (npm): affected all versions; fixed in 3.39.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48128/ (Markdown: https://insights.sbomify.com/CVE-2026-48128/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48128
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48128
- OSV: https://osv.dev/vulnerability/CVE-2026-48128

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48128/
Summaries are generated and may contain mistakes; the official description above is the record.
