# CVE-2026-48146: Budibase: SSRF via OAuth2 Config Validation — Missing fetchWithBlacklist Protection

> A Builder user can exploit missing SSRF protection in OAuth2 config to access internal services and exfiltrate sensitive data.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-g6qx-g4pr-92v7

## What is CVE-2026-48146?

CVE-2026-48146 is a high-severity server-side request forgery vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.39.0, the OAuth2 token fetch function in packages/server/src/sdk/workspace/oauth2/utils.ts uses raw fetch(config.url) with no SSRF protection. The safe wrapper fetchWithBlacklist() exists in the same codebase and is used in every other outbound HTTP call (automation steps, plugin downloads, object store), but was not applied to the OAuth2 token endpoint. A user with BUILDER role can point the OAuth2 token URL to internal services (CouchDB, cloud metadata) to exfiltrate sensitive data. This vulnerability is fixed in 3.39.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-48146?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions | 3.39.0 |
| `@budibase/server` | npm | All versions | 3.39.0 |

## How do I fix CVE-2026-48146?

Upgrade @budibase/server to 3.39.0 or later.

## Is CVE-2026-48146 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48146 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48146 and fix it if it is affected.

What it is: CVE-2026-48146 is a high-severity server-side request forgery vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48146 exists.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions; fixed in 3.39.0
- @budibase/server (npm): affected all versions; fixed in 3.39.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48146/ (Markdown: https://insights.sbomify.com/CVE-2026-48146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48146
- OSV: https://osv.dev/vulnerability/CVE-2026-48146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48146/
Summaries are generated and may contain mistakes; the official description above is the record.
