# CVE-2026-48148: Budibase: Unvalidated VectorDB Host Parameter Enables SSRF

> Authenticated builders can trigger server-side requests to internal IPs or cloud metadata via unvalidated VectorDB host parameters, risking data exposure.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-cv96-5348-p5p8

## What is CVE-2026-48148?

CVE-2026-48148 is a medium-severity server-side request forgery vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.35.3,  the VectorDB configuration endpoint in Budibase accepts a host parameter that undergoes no validation against internal IP ranges, reserved hostnames, or URL schemes. Any authenticated user with builder-level access can supply an arbitrary host value such as 169.254.169.254 or localhost, causing the server to initiate outbound TCP connections to internal network addresses or cloud metadata endpoints on their behalf.This vulnerability is fixed in 3.35.3.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-48148?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions | 3.35.3 |
| `@budibase/server` | npm | All versions | 3.35.3 |

## How do I fix CVE-2026-48148?

Upgrade @budibase/server to 3.35.3 or later.

## Is CVE-2026-48148 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48148 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48148 and fix it if it is affected.

What it is: CVE-2026-48148 is a medium-severity server-side request forgery vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48148 exists.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions; fixed in 3.35.3
- @budibase/server (npm): affected all versions; fixed in 3.35.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48148/ (Markdown: https://insights.sbomify.com/CVE-2026-48148/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48148
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48148
- OSV: https://osv.dev/vulnerability/CVE-2026-48148

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48148/
Summaries are generated and may contain mistakes; the official description above is the record.
