# CVE-2026-48149: Cross-site scripting in budibase

> Stored XSS in Budibase Text component allows BASIC users to execute JavaScript in admin sessions via unsanitized Markdown rendering.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-57p7-9h9w-xqpw

## What is CVE-2026-48149?

CVE-2026-48149 is a high-severity cross-site scripting vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.39.0, the Budibase Text component renders markdown by assigning marked.parse(markdown) straight to innerHTML with no sanitizer (packages/bbui/src/Markdown/MarkdownViewer.svelte:22). Any column a builder binds to a Text component in Markdown mode is a stored-XSS sink writable by every BASIC app user with WRITE on the underlying table. This vulnerability is fixed in 3.39.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-48149?


## How do I fix CVE-2026-48149?

No fix has been published for CVE-2026-48149 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-48149 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48149 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48149 and fix it if it is affected.

What it is: CVE-2026-48149 is a high-severity cross-site scripting vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48149 exists.

Affected product: budibase. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48149/ (Markdown: https://insights.sbomify.com/CVE-2026-48149/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48149
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48149
- OSV: https://osv.dev/vulnerability/CVE-2026-48149

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48149/
Summaries are generated and may contain mistakes; the official description above is the record.
