# CVE-2026-48150: Budibase: Workspace-scoped builder escalates to global admin via /api/public/v1/roles/assign

> Workspace-scoped builders can escalate to global admin privileges via the public API, requiring an Enterprise license with the expanded public API feature enabled.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-6xp4-cf37-ppjh

## What is CVE-2026-48150?

CVE-2026-48150 is a critical vulnerability in budibase, published on 27 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.39.0, /api/public/v1/roles/assign is guarded by the builderOrAdmin middleware, which passes any user who is a builder for the app id in the x-budibase-app-id header. That check admits both global builders and workspace-scoped builders (builder.apps set but builder.global unset). The controller then spreads the request body into the SDK call, and the SDK grants builder.global=true or admin.global=true on whichever user ids the caller supplies. Bob, a workspace-scoped builder with an API key, promotes himself or any other user to global admin with one POST. The whole flow is tenant-wide privilege escalation from an app-level role, available to anyone with an Enterprise license that unlocks the EXPANDED_PUBLIC_API feature. This vulnerability is fixed in 3.39.0.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes)

## Which versions are affected by CVE-2026-48150?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions | 3.39.0 |
| `@budibase/server` | npm | All versions | 3.39.0 |

## How do I fix CVE-2026-48150?

Upgrade @budibase/server to 3.39.0 or later.

## Is CVE-2026-48150 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48150 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48150 and fix it if it is affected.

What it is: CVE-2026-48150 is a critical vulnerability in budibase, published on 27 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48150 exists.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions; fixed in 3.39.0
- @budibase/server (npm): affected all versions; fixed in 3.39.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48150/ (Markdown: https://insights.sbomify.com/CVE-2026-48150/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48150
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48150
- OSV: https://osv.dev/vulnerability/CVE-2026-48150

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48150/
Summaries are generated and may contain mistakes; the official description above is the record.
