# CVE-2026-48153: Budibase: SSRF via OAuth2 token endpoint URL reaches internal hosts and cloud metadata

> Attackers can exploit missing URL validation in Budibase's OAuth2 token endpoint to access internal network resources and cloud metadata.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-4q6h-8p4v-67vq

## What is CVE-2026-48153?

CVE-2026-48153 is a high-severity server-side request forgery vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to 3.39.0, fetchToken in the OAuth2 SDK makes a POST to a builder-supplied URL with plain node-fetch, skipping the blacklist.isBlacklisted check that every other outbound fetch path in the codebase uses. The Joi schema for the OAuth2 URL has no scheme or host restriction. This vulnerability is fixed in 3.39.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-48153?

2 open source packages ship an affected version, including @budibase/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions | 3.39.0 |
| `@budibase/server` | npm | All versions | 3.39.0 |

## How do I fix CVE-2026-48153?

Upgrade @budibase/server to 3.39.0 or later.

## Is CVE-2026-48153 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48153 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48153 and fix it if it is affected.

What it is: CVE-2026-48153 is a high-severity server-side request forgery vulnerability in budibase, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48153 exists.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions; fixed in 3.39.0
- @budibase/server (npm): affected all versions; fixed in 3.39.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48153/ (Markdown: https://insights.sbomify.com/CVE-2026-48153/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48153
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48153
- OSV: https://osv.dev/vulnerability/CVE-2026-48153

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48153/
Summaries are generated and may contain mistakes; the official description above is the record.
