{"answers":{"affected":"2 open source packages ship an affected version, including slim/slim.","exploited":"There is no known exploitation of CVE-2026-48157 in the wild and no public exploit code.","fix":"Upgrade slim/slim to 4.15.2 or later.","what":"CVE-2026-48157 is a medium-severity cross-site scripting vulnerability in slimphp Slim, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-48157 and fix it if it is affected.\n\nWhat it is: CVE-2026-48157 is a medium-severity cross-site scripting vulnerability in slimphp Slim, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-48157 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- slim/slim (Packagist): affected from 4.4.0; fixed in 4.15.2\n- slim/slim (Packagist): affected from 4.4.0; fixed in 4.15.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-48157/ (Markdown: https://insights.sbomify.com/CVE-2026-48157/index.md)","id":"CVE-2026-48157","markdown":"https://insights.sbomify.com/CVE-2026-48157/index.md","name":"CVE-2026-48157","record":{"aliases":["GHSA-53h4-8rc4-f539"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP micro framework","requires_auth":"none","summary":"Attackers can inject JavaScript via unescaped error titles in Slim framework if developers pass untrusted data to exception setters.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Slim is a PHP micro framework that enables users to write simple web applications and APIs. In versions 4.4.0 through 4.15, if an application uses HttpException::setTitle() and/or setDescription() to include untrusted/request-derived data in the error title or description (e.g. \"No products found matching '{$query}'.\"), an attacker could inject arbitrary HTML/JavaScript that executes in the victim's browser when they encounter an HTML error page generated by Slim. The vulnerability is present even with displayErrorDetails = false as the unescaped title and description are rendered on this error path. Built-in exceptions (HttpNotFoundException, HttpBadRequestException, etc.) ship plain-text defaults, so a vanilla Slim app with no user code is not exploitable. Only applications that feed untrusted data into setTitle() and/or setDescription() are affected. The issue has been fixed in 4.15.2. If developers are unable to immediately update their applications, they can work around this issue by avoiding passing untrusted/request-derived data into HttpException::setTitle() and setDescription() and using static, plain-text error copy instead.\nThey should also register a custom error renderer (an ErrorRendererInterface implementation, or a subclass of HtmlErrorRenderer that escapes the title and description) for the HTML media type.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Slim has Reflected XSS in the HtmlErrorRenderer","id":"CVE-2026-48157","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"use-context-selector was vulnerable to malicious code execution via compromised commits","id":"CVE-2026-48158"},"packages":[{"ecosystem":"Packagist","fixed":["4.15.2"],"introduced":["4.4.0"],"last_affected":[],"package":"slim/slim","purl":null,"source":"GHSA-53h4-8rc4-f539"},{"ecosystem":"Packagist","fixed":["4.15.2"],"introduced":["4.4.0"],"last_affected":[],"package":"slim/slim","purl":"pkg:composer/slim/slim","source":"GHSA-53h4-8rc4-f539"}],"prev":{"headline":"pypdf: Possible long runtimes for zero-only width values in cross-reference streams","id":"CVE-2026-48156"},"products":["Slim"],"published":"2026-06-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-16","vendors":["slimphp"]},"summary":"Attackers can inject JavaScript via unescaped error titles in Slim framework if developers pass untrusted data to exception setters.","url":"https://insights.sbomify.com/CVE-2026-48157/"}