# CVE-2026-48165: MariaDB: unsafe usage of `wsrep_sst_receive_address` values on the joiner side

> A high-privileged MariaDB user can execute shell commands on the joiner node by manipulating specific Galera SST configuration variables.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 3 Aug 2026
- **Also known as:** ALPINE-CVE-2026-48165, BELL-CVE-2026-48165, BIT-mariadb-2026-48165, BIT-mariadb-min-2026-48165, BIT-mysql-client-2026-48165, DEBIAN-CVE-2026-48165, ECHO-1eed-ac34-46f2, GHSA-7v3p-h23x-8hwv, MINI-3p2c-r47c-22xw, MINI-48jw-4f2m-cxjm, MINI-mfp5-9vfv-jg4g, MINI-rf5g-7329-5373, MINI-v448-cr8g-r3p2, MINI-x6ch-rqmw-fp83, ROOT-OS-DEBIAN-13-CVE-2026-48165, UBUNTU-CVE-2026-48165

## What is CVE-2026-48165?

CVE-2026-48165 is a high-severity command injection vulnerability in Mariadb Mariadb, published on 12 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.27, 10.11.1 to before 10.11.18, 11.4.1 to before 11.4.12, 11.8.1 to before 11.8.8, and 12.3.1, a high-privileged MariaDB user could've used wsrep_sst_receive_address or wsrep_sst_donor global system variables to execute shell commands as the uid of the mariadbd process on the galera joiner node. This issue has been patched in versions 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-48165?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | From 10.6.1 | 10.6.27, 10.11.18, 11.4.12, 11.8.8, 12.3.2 |
| `mariadb-min` | Bitnami | From 10.6.1 | 10.6.27, 10.11.18, 11.4.12, 11.8.8, 12.3.2 |
| `mysql-client` | Bitnami | From 10.6.1 | 10.6.27, 10.11.18, 11.4.12, 11.8.8, 12.3.2 |

Products: Mariadb Mariadb.

## How do I fix CVE-2026-48165?

Upgrade mariadb to a fixed version for your release line: 10.6.27, 10.11.18, 11.4.12 or 11.8.8.

## Is CVE-2026-48165 being exploited?

There is no known exploitation of CVE-2026-48165 in the wild and no public exploit code.

## Other vulnerabilities in Mariadb Mariadb

- [CVE-2026-49261](https://insights.sbomify.com/CVE-2026-49261/): MariaDB server has unsafe parameter handling in `wsrep_notify_cmd` (critical 10.0)
- [CVE-2026-85746](https://insights.sbomify.com/CVE-2026-85746/): MariaDB: Out-of-bound buffer write on in `ST_AsText` of nested GeometryCollections (critical 9.9)
- [CVE-2026-85748](https://insights.sbomify.com/CVE-2026-85748/): MariaDB: Use-after-free with a large number of SYS_REFCURSOR's (critical 9.9)
- [CVE-2026-92262](https://insights.sbomify.com/CVE-2026-92262/): MariaDB: Numerous issues caused by historical #mysql50# tablename encoding bypass. (critical 9.9)
- [CVE-2023-26785](https://insights.sbomify.com/CVE-2023-26785/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48165 and fix it if it is affected.

What it is: CVE-2026-48165 is a high-severity command injection vulnerability in Mariadb Mariadb, published on 12 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48165 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected from 10.6.1; fixed in 10.6.27, 10.11.18, 11.4.12, 11.8.8, 12.3.2
- mariadb-min (Bitnami): affected from 10.6.1; fixed in 10.6.27, 10.11.18, 11.4.12, 11.8.8, 12.3.2
- mysql-client (Bitnami): affected from 10.6.1; fixed in 10.6.27, 10.11.18, 11.4.12, 11.8.8, 12.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48165/ (Markdown: https://insights.sbomify.com/CVE-2026-48165/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48165
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48165
- OSV: https://osv.dev/vulnerability/CVE-2026-48165

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48165/
Summaries are generated and may contain mistakes; the official description above is the record.
