# CVE-2026-48203: Apache Camel-Solr: The SolrParam. and SolrField. Exchange header prefixes used non-Camel-prefixed names that bypass the HTTP header filter, allowing an HTTP client to inject Solr query parameters (server-side request forgery) and document fields

> Attackers can inject Solr parameters via HTTP headers to trigger server-side requests to internal services or metadata endpoints.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-4h4f-v54q-7pq8

## What is CVE-2026-48203?

CVE-2026-48203 is a critical server-side request forgery vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection'), Improper Input Validation, Server-Side Request Forgery (SSRF) vulnerability in Apache Camel Solr component.

The camel-solr producer copies Exchange message headers whose names begin with the SolrParam. prefix into the parameters of the Solr request, and headers whose names begin with the SolrField. prefix into the fields of the indexed Solr document. The prefix constants (SolrConstants.HEADER_PARAM_PREFIX / HEADER_FIELD_PREFIX) were the plain strings SolrParam. / SolrField.. Because these names do not start with the Camel / camel prefix, HttpHeaderFilterStrategy - which blocks only the Camel header namespace on the HTTP boundary - let them pass from an inbound HTTP request straight into the Exchange. In a route that bridges an HTTP consumer (for example platform-http) into a solr: producer, any HTTP client could therefore set SolrParam.* headers to inject arbitrary Solr request parameters - including shards or stream.url, which cause the Solr server to issue server-side requests to an attacker-chosen URL (server-side request forgery, for example to an internal service or a cloud metadata endpoint), or qt to reach administrative request handlers - and set SolrField.* headers to inject arbitrary fields into indexed documents. No credentials are required when the bridging consumer is unauthenticated.
This issue affects Apache Camel: from 4.0.0 before 4.14.8, from 4.15.0 before 4.18.3, from 4.19.0 before 4.21.0.

Users are recommended to upgrade to version 4.21.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.8. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.3. After upgrading, routes that set Solr parameters or fields via the raw header prefixes must use CamelSolrParam. / CamelSolrField. instead of SolrParam. / SolrField.. For deployments that cannot upgrade immediately, strip the SolrParam.* and SolrField.* headers from any untrusted ingress before the solr: producer, and set the required Solr parameters and fields from a trusted source in the route.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-48203?

6 open source packages ship an affected version, including org.apache.camel:camel-solr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-solr` | Maven | From 4.0.0 | 4.14.8 |
| `org.apache.camel:camel-solr` | Maven | From 4.0.0 | 4.14.8 |
| `org.apache.camel:camel-solr` | Maven | From 4.15.0 | 4.18.3 |
| `org.apache.camel:camel-solr` | Maven | From 4.15.0 | 4.18.3 |
| `org.apache.camel:camel-solr` | Maven | From 4.19.0 | 4.21.0 |
| `org.apache.camel:camel-solr` | Maven | From 4.19.0 | 4.21.0 |

Products: Apache Camel.

## How do I fix CVE-2026-48203?

Upgrade org.apache.camel:camel-solr to a fixed version for your release line: 4.14.8, 4.18.3 or 4.21.0.

## Is CVE-2026-48203 being exploited?

There is no known exploitation of CVE-2026-48203 in the wild and no public exploit code.

Public exploit code:

- Reproducer for CVE-2026-48203: Apache Camel camel-solr SolrParam./SolrField. header injection enabling Solr document-field injection and SSRF via the shards parameter (fixed in 4.14.8/4.18.3/4.21.0) (github_poc): https://github.com/oscerd/CVE-2026-48203

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48203 and fix it if it is affected.

What it is: CVE-2026-48203 is a critical server-side request forgery vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48203 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-solr (Maven): affected from 4.0.0; fixed in 4.14.8
- org.apache.camel:camel-solr (Maven): affected from 4.0.0; fixed in 4.14.8
- org.apache.camel:camel-solr (Maven): affected from 4.15.0; fixed in 4.18.3
- org.apache.camel:camel-solr (Maven): affected from 4.15.0; fixed in 4.18.3
- org.apache.camel:camel-solr (Maven): affected from 4.19.0; fixed in 4.21.0
- org.apache.camel:camel-solr (Maven): affected from 4.19.0; fixed in 4.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48203/ (Markdown: https://insights.sbomify.com/CVE-2026-48203/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48203
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48203
- OSV: https://osv.dev/vulnerability/CVE-2026-48203

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48203/
Summaries are generated and may contain mistakes; the official description above is the record.
